Operating system not found after installation of OpenSUSE 11

I’ve installed OpenSUSE 11 several times, but I’m having a problem with one installation. I think it’s because I changed the size of the partitions. Does anyone know how to correct this problem?

I’m currently accessing this forum from a computer with identical hardware as the computer with the problem. It is also running OpenSUSE 11, the only difference is I didn’t change the partition sizes when I installed the software.

After completing the installation, I can log on and do everything normally, but when I boot the computer it tells me it can’t find the operating system. I tried the repair features on the DVD, which are great by the way, and told it to reinstall the boot loader and MBR, but it didn’t help.

I have one 300GB disk drive in the computer. I told the installation to use the entire hard drive, then changed the size of the partitions. I did this because I expect to increase the memory in the computer. It creates the standard three partitions, sda1, 2, and 3. I changed the swap partition from 2GB to 8GB, changed the root partition from 20GB to 50GB, and put the remainder in the home partition, 221.4GB. I could see all of the partitions and access the root and home partitions.

Thank you.

Had a similar problem when I changed my harddisk. Booting from a live cd and executing “grub --install” did it for me.
You could also check /boot/grub/menu.lst for errors.

Thanks for the info. That definitely showed that the partitioning is the problem. When I tried to access the boot loader from yast while running the live CD, it popped up a dialog that said “Error Because of the partitioning, the boot loader cannot be installed properly”. I couldn’t find an answer to this problem, at least not one in English, so it looks like I’ll be reinstalling openSUSE and dealing with the need to change the swap partition later. But it would be nice to know more about the problem, for example is there a limit on the size of the swap partition?

The problem was the 8GB swap partition. When I reinstalled openSUSE 11 I left the swap partition at 2GB, but increased the root partition to 50GB, and it works.

I’ve installed with different install configurations and unless I allow it to start the OS using the installer cd ‘boot to disk’, it just gives me the 'missing operating system. I’ve tried it on a few different workstations (Dell OptiPlex 260 and Compaq Evo D51S) and both result in the same, missing operating system. I’m using a swap partition of 4GB. Is there a problem with the swap being bigger than 2GB?

i don’t think that the swat is the only problem, i got the same error after change some bios parameters (i.e. the system date)

Also had identical problem with 64bit OpenSuSE11 (but not with 32 bit) cured by having 2 Gbyte swap partition rather than 8