Opera - torrent - never worked


According to official Opera Website http://help.opera.com/Linux/9.01/en/bittorrent.html Opera is capable of downloading Bit Torrents file with built-in software.
It never worked for me. Even with the previous systems.

When I try to download suse.iso file via torrents, Opera just downloads torrent file (configuration file) and saves it to my disk. Then I have to use external software do download that file. It is also true with other torrents. The same with magnets.

How can I fix? I’d be so happy to use Opera to download torrents. Are there any special settings in Opensuse Opera where I can set it?

Since you’re on KDE: install ktorrent. Do not forget to open it’s listening port in the YaST Firewall module.

Thanks for first reply. I do have ktorrent and it works find. But that’s not what I want.
I want to run built-in torrent client in Opera.

Took a look at Opera from the OSS.

Natively, it does not know how to handle a torrent file, it prompts to launch xdg-open, which then tries to open the file in the default web browser. Also verified superficially by skimming the Opera advanced settings and extensions, there is nothing installed that suggests support for torrent files.

So, I then looked at what kind of extensions might be installed, curiously there are some extensions for torrent search engines which no longer exist and a utorrent extension. Surprised, since utorrent only installs on Windows. Installed it anyway to see what it is.

Apparently the utorrent extension only maps and hands off a torrent file to an installed regular utorrent app (which only installs on Windows), so that extension is useless wherever Opera might be installed not on Windows.

Clicked on the link to “upgrade Opera to latest” and it started to download a deb file which is when I decided to stop exploring.
Maybe some latest version of Opera might be different but that’s for someone else to determine.


Please be aware that the docs you’re referring to are for Opera 9, which was years ago. AFAICS now the internal bittorrent client was dropped from version 15, so it’s not going to work the way you want it.

Thanks a lot.

So our conclusion is it won’t work.

a bit off topic but the only “working” web torrent is (or was as it doesn’t work with Quantum) Torrent Tornado a Firefox 56 (and ESR)addon
as LEAP is stuck with Firefox-ESR the above should work until opensuse decides to replace ESR with Quantum which might be with LEAP 15 (or not as I have no idea)
I’ve never used the above extension a quriosety about it is that it only downloads from a bittorrent swarm it doesn’t upload
when ever I needed to use a torrent client under opensuse I used qBittorrent as I find it a bit more polished and stable then ktorrent, ktorrent does not work with tracker-less magnet links
for example if you try to download the current LEAP torrent: openSUSE-Leap-42.3-DVD-x86_64.iso 4.32 GB from a tracker-less magnet
ktorrent will do nothing it will stall, qbittorrent will get the torrent file from only from the hash without the need for a tracker and then download it, I’m not sure how it does that maybe it caches url’s of popular or open trackers it’s one of the reasons I avoid ktorrent