Opera 9.64 JAVA

Every thing works fine in ff3.5 as far as java and applets go, but not in Opera 9.64. I need the correct path according to the directions as listed below: I have tried these two paths and although they are valid, it still does not work.

Opera uses the Java 2 Runtime Environment (JRE) directly, rather than through the use of a Web browser plug-in. Before proceeding, you may wish to test Java to see if Opera has been able to auto-detect your Java installation using our test applet. If Opera does not show this applet (an animated analog clock), you can try adding the correct Java path for your system in Opera’s preferences:
Go to Tools > Preferences > Advanced > Content.
Click the “Java options” button. If this button is dimmed, first check the “Enable Java” option.
Click the “Choose” button for the “Java path” field.
Navigate to the Java directory and click “OK”. The path you are looking for is the directory of your Java installation containing the files libjava.so and libawt.so. On the command line, type: find / -name libjava.so 2> /dev/null
For example, on a Debian system, the path is: /usr/lib/jvm/java-1.5.0-sun/jre/lib/i386
Click the “Validate Java path” button. If you get an error message, try again with a different path.
Click “OK” to save your changes and exit the Java dialog.
Click “OK” to save your changes and exit the Preferences dialog.

My java is listed to: /usr/lib/browser-plugins/javaplugin.so

Enabling Java in Opera for Linux - Opera Knowledge Base
Enabling plug-ins in Opera for Linux - Opera Knowledge Base

May help

If I go to Java Options and paste your path and try to validate it, it says Could not find a valid Java installation.

Enter another directory and try again.

In the usr/lib/browserplugins the libflashplayer.so and the livejavaplugin_oji.so

are grayed out.

Interesting, the applet test for opera 9.64 does not show the clock using ubuntu or Suse but the morningstar applet works in ubuntu.

linux-6y9y:/home/rosswmcgee # find / -name libjava.so 2> /dev/null
linux-6y9y:/home/rosswmcgee #

Tried this path no dice.

Thing is Opera is 32 bit isn’t it? Or am I mistaken?

Not sure, but I do know Opera’s applets were working when FF3.5 was working, before we went through all the work together gettin FF3.5 applets to work again. You would think if one works the other would too
Why when I enable Java does it not stay enabled. Any way this is a valid path but it does not do the job:


The path looks like it should be


That is exactly what I thought it should be. Opera will not validate it. This is the msg. I get:

Could not find a valid Java installation.

Enter another directory and try again.

When I use the file sys to track down the files in that path they are all there.

In hidden files /home/username/.opera

rename .opera to .opera_old

start opera
see if it sets up any better.

No it did not work. It did wipe out my bookmarks email and address book in the .opera file. I moved the .opera_old file to trash. Will at this point remove opera and re-install, see if that works. Oh well it was worth a try, and thankyou.

OK I re-installed Opera. Interestingly the correct path as we both agree is the correct path, will not validate. So there is a bug here, at least I think so.

I’ve been using Opera 9.64 for months with my own install of Java.

Here’s my path in Preferences/Advanced/Java Options


I had to install my own version of Java to get it to run correctly.


I tried it and it still gives me a no validate verdict. What java is checked in software management in your set up?

Just for the heck of it mine is


Could not find a valid Java installation.
Enter another directory and try again?

So when it says this does it not mean we have to add a valid java installation, and if so what is it? I tried adding some other Java
in qt, but they made no diff, so I went back to the original plan that you sent me. FF3.5 works fine, but I am the sort that likes to fix problems, though I guess it is not necessary. In terminal I get this:

linux-6y9y:/home/rosswmcgee # /usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre/lib/amd64/libjava.so

If I walk through the file sys though it is there.
Segmentation fault
linux-6y9y:/home/rosswmcgee # find linux-6y9y:/home/rosswmcgee # /usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre/lib/amd64/libjava.so
find: `linux-6y9y:/home’: No such file or directory
linux-6y9y:/home/rosswmcgee # Segmentation fault
bash: Segmentation: command not found
linux-6y9y:/home/rosswmcgee # linux-6y9y:/home/rosswmcgee #
bash: linux-6y9y:/home/rosswmcgee: No such file or directory
linux-6y9y:/home/rosswmcgee #

Do you have


Yes that file is in the the suse 11.1 system.

This is the Opera plugin path:


This is the Java Path:


After starting Opera and go to content, Java is always unchecked. To check the path I must enable Java. I guess there is a valid reason for this? Also the Java path is always not validated. Question, does Opera validate your path?

Post the output of

zypper se -s opera

linux-6y9y:/home/rosswmcgee # zypper se -s opera
Retrieving repository ‘ndex of /update/11.1’ metadata [done]
Building repository ‘ndex of /update/11.1’ cache [done]
Loading repository data…
Reading installed packages…

S | Name | Type | Version | Arch | Repository
i | opera | package | 9.64-1.1.1 | x86_64 | ndex of /update/11.1
v | opera | package | 9.63-1.1 | x86_64 | ndex of /update/11.1
v | opera | package | 9.64-1.1.1 | i586 | ndex of /update/11.1
v | opera | package | 9.63-1.1 | i586 | ndex of /update/11.1
v | opera | package | 9.62-2.3 | x86_64 | openSUSE-11.1-Non-Oss
v | opera | package | 9.62-2.6 | i586 | openSUSE-11.1-Non-Oss
| opera | srcpackage | 9.64-1.1.1 | noarch | ndex of /update/11.1
i | opera | patch | 629 | noarch | ndex of /update/11.1
i | opera | patch | 366 | noarch | ndex of /update/11.1
linux-6y9y:/home/rosswmcgee #