OpenVPN - 11.2 default Route wrong

Hello there…

I just installed OS 11.2 and wanted to set up my Internet connection in school.
There is a open Wlan with no encryption and a .ovpn and a .cer is provided to use with Openvpn.
In 11.1 everything worked fine for me but in 11.2 i got this message during the connect:

NOTE: unable to redirect default gateway – Cannot read current default gateway from system

A tun0 device is created and connects. The Problem is, that my Routing is not as it should.

Route gives me:

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface * UH 0 0 0 tun0 * U 2 0 0 wlan0
default UG 0 0 0 wlan0
default UG 0 0 0 wlan0

I looked into my friends Table (he uses Ubuntu) and understood, that i have to set my default route to the “Ref” from the first line.


route del default
followed by a
route add default gw

solved my Problem and now I’m able to write these lines.

But shouldn’t OpenVPN do this for me?

SuSE Firewall is turned off, I tried also different OpenVPN versions (2.0.9 from OS11.1, compiled the newest) Tried setting up my connection with networkmanager or ifup.

at the moment i use OpenVPN 2.1_rc18 from the Standard Repository where the “NOTE” is gone but the Problem remains.

Does anyone know if something changed to network setup from YaST which openvpn can’t deal with or is there somthing i missed to think of?