Opensuse12.2 grub2 upgrade never works , is it compatible .

Hi ,

I am trying to upgrade opensuse12.2 to 12.3 and subsequently to 13.2 but the main problem I am facing is the system fails to boot after upgrade to 12.3 saying partition not found . I am using citrix xenserver vms .

I can manually install the bootloader after upgrading it to 12.3 by using an iso image and booting it to rescue mode but I am looking for an automated process where it upgrades to 12.3 and reboot to the new version .

Since I think it is a grub2 issue , I have tried a fresh 12.2 image to upgrade to grub2 before upgrading to opensuse 12.3 but it fails with the same error .

I did the following for the grub2 upgrade :
On the running system , run grub2-install /dev/xvda
grub2-mkconfig -o /boot/grub2/grub.cfg

cannot boot , partition not found error .

let me know if I am doing something wrong .

Do you have paravirtualized or HVM guest? I would assume PV judging by device names. In which case I am not even sure if grub2 in 12.2 supports PV xen platform.

How did you install this guest? Was it installed as PV initially? Was grub2 selected during installation or added later?

These are paravirtual guests with default grub installs and the plan is to update grub to grub-2 or just upgrade the whole OS to opensuse12.3.

Opensuse 12.3 works with grub2 on the para virtual guest after upgrade but needs a manual grub update which is not preferred in this case . I am looking into automating the whole thing .

Since I didn’t get any reply , I went with my old ways of fixing bootloader by specifying kernel and ramdisk in PV-bootloader-args and booting up oss12.3 after the upgrade .

After subsequent upgrades to 13.2 PV-bootloader-args option is no longer required as it is already fixed and can be removed and the OS can be booted normally .