opensuse12.1 and Xen: VM boot error


I have a HP Proliant with a hardware raid 5 disk subsystem where 7 logical disks defined
I have installed the Xen kernel and can boot without problem with systemV or systemd.
I have installed the Xen tools and the network bridge br0 is working

I use disk 5 for the VM

fdisk for this disk is

Disk /dev/cciss/c0d5: 104.9 GB, 104857436160 bytes
255 heads, 63 sectors/track, 12748 cylinders, total 204799680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00014229

           Device Boot      Start         End      Blocks   Id  System
/dev/cciss/c0d5p1   *         63   204796619   102398278+   f  W95 Ext'd (LBA)
/dev/cciss/c0d5p5        40178628   204796619    82308996   83  Linux
/dev/cciss/c0d5p6             189      17687564     8843688    83  Linux
/dev/cciss/c0d5p7        20980953     40178564     9598806    83  Linux
/dev/cciss/c0d5p8        17687628     20980889     1646631    82  Linux swap / Solaris

Partition table entries are not in disk order

I can start the creation of the VM with Yast
c0d5p5 is used /home
c0d5p6 as /var
c0d5p7 as /
The grub is written to the MBR

The installation works until the first reboot where it lock
I see that in /etc/xen/vm I have the VM definition files

When I try starting the VM in Yast i receive the boot choice but the following error is displayed >:(

Booting XEN Opensuse 12.1- 3.1.0-1.2
root (hd0,6)
Filesystem type is extf2s, partition type 0x83
kernel /boot/vmlinuz- 3.1.0-1.2-xen root=/dev/xvda7 resume= /dev/xvda8 splash = silent, quiet

Error 13 : invalid or unsupported executable format 
Press any key to continue ..

Any idea what can be the problem?


Based on this thread…

[SOLVED] Booting Vista via grub: Invalid or unsupported executable format](

…try adding a “makeactive” in GRUB’s boot command?

And just double-check your device mappings:

[VM] /dev/xvda7 → c0d5p7 [host]
[VM] /dev/xvda8 → c0d5p8 [host]

(Although those are probably correct, since you used the same numbering.)


First of all, it looks like you are using full virtualization mode (HVM) — there is no point for this with openSUSE, use paravirtualization both for installation and production. By the way, when you boot a DomU with pyGRUB (which works completely from Dom0), it doesn’t matter whether DomU’s disk has bootable MBR or “active” partitions.

Second, the “-xen” kernel supplied by openSUSE seems to be capable of running as Dom0 and DomU, but not in bare-metal mode, while HVM is just like a bare-metal environment for a DomU kernel. If you really need to stay in HVM, use standard “-desktop” or “-vanilla” kernel. Alternatively, you can build your own Xen-enabled kernel from upstream sources, and such a kernel would be able to run in all modes (bare-metal, Dom0, DomU), but less compatible with openSUSE userland.

I highly recommend to switch to PV mode though. With HVM, you just loose performance for nothing; leave it to Windows and other non-PV systems.

thanks for your advice.

I tried adding makeactive but the error changed Error 12 memory problem?

I use paravirtualization.
After some search I’m thinking that the problem is maybe in the Opensuse 12.1 32 bit that I used for the the VM.

The host dom0 is a XEN X86-64 version and the VM installation is done with an Opensuse 12.1 32 bit. This worked in Opensuse 11.2
I’ll try to install the VM with the Opensuse 64 bit version.

Many thanks