openSUSE11 iSCSI installation problem

What is the correct procedure for installation of iSCSI-target in a openSUSE11 32-bit system ??

I’ve installed the following packages (that comes with openSUSE11) :
iscsitarget
yast2-iscsi-server

Using Yast2:s iSCSI target setup i’ve selected :
Service start at boot & selected my LUN 0 as /dev/sda8 (an unformatted partition) of type fileio and no authentication.

After exiting this setup I get an X-message :

YaST got signal 6 at YCP file IscsiServer.ycp:121
/sbin/yast2: line 421: 3847 Aborted $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

Whats wrong ???

Hi,

Find here the detailed procedure:
12.0 Mass Storage over IP Networks—iSCSI

Novell Documentation

It applies to SLES 10 SP2, but it is not different than in Open Suse.

Regards.

Thanks for your advice.
I’ve tried to follow the SLES manual instructions, but there seeems to be some differences.

I would be very grateful for some guidance…

I’ve installed iscsi-target + iscsi-kmp-default + iscsi-kmp-pae.

When editing /etc/ietc.conf i’ve added :
Target iqn.2001-04.com.example:linux-ltpr
Lun 0 Path=/home/testfile, Type=fileio

Restarting the service by
/etc/init.d/iscsitarget restart
indicates everything ok (no error messages).

The SLES manual suggests checking if everything is OK in /proc/net/iet/volumes but i have no /proc/net/iet directory ( and because of this no /iet/volume file).

ps-command indicates a running ietd process but nothing like “iscsi” etc.

So i dont know how to check if i have a working iscsi server & I cant find the taget by using iscsi-initiator.

Any ideas ???