opensuse11 can't find hard disks

Tried and tried to install opensuse11 (from CD or DVD) on my hdd but it says “cannot find hard disk, please check your hardware!” as though I have no hdd installed. My disk is a Western Digital, Windows works fine on it, and so does Suse 10.0 which I have installed correctly on it.

Obviously I thought it’d be simple to upgrade from 10.0 to 11 but it’s not so far. Is there a way to upgrade from an iso within my present install of Suse 10.0? Or is there any other way to solve this problem?

Thanks for your help.


Did you run a media check before installing ?
Western digital should not be problem.

Hello, thanks I’ll try a media check then get back to you. If it’s a disc (CD/DVD) problem I’ll order one via post or something…

I did a media check on both the CD and DVD, both were corrupted or broken so at least there’s hope for me yet.

when burning the dvd and cd burn at the slowest speed your software allows

Thanks I will do that. It’s my fault I guess, my DVD download via HTTP went into minus figures for some reason under Suse 10 and so I figured that as it was minus it had already finished downloading. It appears I was wrong. The CD was the last blank one I had in the house as well and I burnt it under Windows but it obviously didn’t work either.

I’m just looking online to see where I can purchase the DVD from.

Sorry to post in my own thread again but I literally just finished downloading the DVD .iso of opensuse11 and my Firefox downloads box showed 4.3 GB downloaded but Windows says its size on disk is 4.28 GB (4.28 GB (4,602,126,336 bytes) is this the correct size?

I’m going to burn the disk in a second but I thought I’d ask as well.

Thanks everybody.


I do not why I find this advise more often , I burn always at the speed recommended by the manufacture
of the bland Cd OR DVD and that is mostly 16 X speed
never get a problem

I never get problems with burn speed either to be honest but using the slowest speed seems like good advice in my case as it eliminates one other variable which could potentially corrupt my disk(s). As it happens I think that it was because I used a different burning program and downloaded the DVD image, as well as burnt it, from within Suse 10.0 which I’m unfamiliar with.

I’m just verifying the burnt DVD in Nero under WinXP, I’m sure the image I downloaded yesterday was only some 2.6 GB in size when I used Suse 10.0 to do the download hmmmmm

protheory wrote:
> is this the correct size?
> I’m going to burn the disk in a second but I thought I’d ask as well.

do NOT burn that disk before you read: "In all cases, after
downloading: be certain to do an md5sum check of the downloaded file
vs the posted md5sum value

and all the other GREAT advice found in the thread named “NEWBIES -
Suse-11.0 Pre-installation - PLEASE READ” found at

don’t even think about burning until you know for SURE that you have
a perfectly good image!

of course, if you enjoy burning disks into worthless coasters, go ahead…

DenverD (Linux Counter 282315) via NNTP, Thunderbird, KDE
3.5.7, SUSE Linux 10.3, #1 SMP i686 athlon

I already burnt it but thanks for the advice. I was going to use the torrent checksum method but it was painfully slow downloading so I used plain old HTTP instead. I don’t know how to use the checksums as when I click on the link (using Firefox under WinXP) to them on the opensuse main download page it’s just a text file with three lines. I’m willing to learn but at the current moment I consider it worth the risk of a disk , although by the next time I need to do this I’ll hopefully have learnt how to verify with the checksum. The link you posted gives me a 404 error but again, thanks for helping.


> never get a problem

maybe when your burner’s lens has just a little bit more gunk on it
(from pollution) then you will know why…

DenverD (Linux Counter 282315) via NNTP, Thunderbird, KDE
3.5.7, SUSE Linux 10.3, #1 SMP i686 athlon

I burnt the image onto DVD with Nero, then verified it within Nero. I used the DVD to verify the media again on bootup. I booted fine from the DVD until it came to partitions again when it offered no hard disks to partition, the install still won’t see my HDDs, even though Suse 10.0 is installed on the same disk with no problems.

Any advice?

> the install still won’t see my HDDs, even though Suse 10.0 is
> installed on the same disk with no problems.

this is a really strange problem…
is it a SATA disk?

ah!!! google this search string:
western digital linux problem
and get 2.39 Million hits!!!

then, find YOUR WD model number and enter it kinda like:
western digital 12345-X (or whatever) linux problem

and see what pops up…
good luck.

see caveat:
DenverD (Linux Counter 282315) via NNTP, Thunderbird, KDE
3.5.7, SUSE Linux 10.3, #1 SMP i686 athlon

Thanks, it’s a little frustrating to say the least. Well, it looks like it’s definitely a hardware compatibility problem as I’m currently installing the same .iso DVD image I previously burnt only it’s on VMWare, the download must be good, I’ve checked it three separate times with three separate programs now and 3 is a magic number.

I’ve been wanting to go to Linux since RedHat 8 which I bought when it was the newest thing but my AOL internet and modem put paid to internet access so I lost interest. Now I’ve got an ethernet router connection I can get all my virtual machines online using bridged networking which is VMWare’s default. I click next…next…next and hit ‘start virtual machine.’ This is of course under Windows and on a different box.

My reason for choosing opensuse 11 is for the default install of VirtualBox specifically more than anything else. I wanted to virtualise Windows under Linux, set the install to bridged networking and presto I’m sorted. Tried lots of other distros but I can’t get VMWare or VirtualBox to install on any other distro so with OS11 I thought I was on a winner. This isn’t the only reason for me choosing OS11 but it’s beyond this topic to discuss.

So I’ve got a dedicated spare box, Western Digital 80GB HDD, 256mb RAM (have spare 512 stick also), 2.4 GHZ Celeron CPU. Opensuse won’t install as my previous disks were corrupted and now I know it’s definitely a (probably random) hardware incompatibility. Regardless of the reasons or solutions, the reality is that no matter what I do OS11 won’t install on this machine as it is.

Next plan is, if it’s compatible hardware, install VMWare’s free ESXi virtual server thingy on bare bones then run opensuse11 through that which, again if my hardware is compatible with VMWare’s product, should give me the closest thing to bare bones performance while simultaneously solving the HDD issue by virtualising the HDD. I know for a fact that this works for the .iso DVD image I downloaded as it’s installing as I type onto VMWare Workstation under WinXP.

If the VMWare ESXi thing isn’t compatible with my box I’ll have to install WinXP on it then stock it up with RAM and see how fast I can get OS11 to run. I’ve been running it virutally under my WinXP Pro box (120GB Seagate HDD, 1GB RAM, 2.0 GHX CPU) for a while and it’s passably fast. I often boot into full screen and use OS11. My only problem then is that I can’t install it directly onto my spare box so I’ll have to look at other options.

I’m learning a lot so it’s all good

protheory wrote:

> I’m learning a lot so it’s all good

THAT is the spirit…keep at it, and you will soon be offering
advice to newer penguins here :slight_smile:

DenverD (Linux Counter 282315) via NNTP, Thunderbird, KDE
3.5.7, SUSE Linux 10.3, #1 SMP i686 athlon

It couldn’t be a BIOS setting could it??

I just had to set my sata from (AHCI) to compatibility in BIOS of my new laptop - Though Suse could read my disc either way, it was XP that couldn’t. I had erased a pre installed Vista system and recovery partition - to give me clean drive. XP wouldn’t pick the drive up. I did a bit of head scratching and decided to look through BIOS to see what might be wrong. 1st guess and I was right - (AHCI)

Thanks, I’ve finally got OS11 installed, albeit on a virtual machine, but it works :slight_smile: I installed VirtualBox from the online repository first time, and I also upgraded it to the latest 2.0.2 version by downloading the package from Sun’s website, it worked first time.

I’ve looked and looked at my BIOS and I don’t think it’s that causing the problem although I can’t be 100% sure. My BIOS, on my spare machine, is from 2002 by AMI and the settings are limited. I might risk it and try a dual boot install on my WinXP box to see if that performs any diffferently as it’s a different BIOS. My HDD is definitely not SATA, they’re all IDE.

If you are coming from 10.0, there is a distinct possibility that the kernels module for your disk controller (it’s the controller that matters, not the disk itself) has changed. In particular, libata is now used for all IDE & SATA disks, which wasn’t the case for IDE prior to 10.3. Besides libata, there will be another driver for the specific controller device, which is probably in the chipset (rather than a discrete device). Finally, it sometimes happens that a change in the kernel requires it being given a particular parameter to work with certain hardware; this tends to be true with older chipsets and especially older bios’s.

Try adding this boot argument (in the box below on the menu):


If that doesn’t work, try adding these:


If none of that works, I would use a Live-CD. Live-CD’s boot with many more kernel modules (precisely for this reason), and from there, we should be able to find what the DVD is missing in its detection. IMO the Knoppix CD is the best for this purpose; it loads nearly everything. Once you can boot, you can use the following command to find the disk controller:


And then google it. You can also use this command to see all the modules the CD loaded


and from that list back into what’s missing in the DVD boot, and then you can instruct the DVD to load that particular module.