openSUSE11.4 KDE: Too many pulseaudio aplets in task bar


I have openSUSE 11.4 KDE 64-bit. Right now I have 20 identical pulseaudio applets that each looks like a circuit board or a PCI adapter on my computer’s taskbar. I tried uninstalling then re-installing pulseaudio and the package that choose device (padev?) many times but this problem remains.

I would very much appreciate your suggestions.


On 05/30/2011 07:06 AM, taytong888 wrote:

> Right now I have 20 identical pulseaudio applets

did this 11.4 install begin it life with this problem? or, did this
problem show up after weeks or months of not having it?

> I would very much appreciate your suggestions.

i would suggest, if it was a problem from the very first hour of the
install to do this: because you have a bad
install for some reason, maybe the reason is a corrupt install disk…

but, if this is a new problem after weeks (or even just hours) of not
having the problem i would suggest that you undo what was done to cause
it…maybe that was something you edited, deleted, replaced, updated,
tuned, customized, etc etc etc etc…

if you have no clue what happened, then i’d suggest you use YaST to add
a new test user, then log out, and log back in as the test user and see
if the problem goes away…if so, the fault is somewhere in

finding that fault is not gonna be easy…tell us, have you ever
installed anything from any repo with Factory, Playground, Unstable or
Tumbleweed in its address/description?

and, if 11.4 was not the first linux on this machine: how did you get to
11.4 from whatever preceeded it? (that is, i’m wondering what kind of
bits and pieces might be left over from previous installs…)

[NNTP via openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

These icon are on the taskbar you say. Are they perhaps in the Systemtray? What happens if you click on one of those icons? Does a menu open that has the menuentry “Preferences”?

If yes, go to these prefs and uncheck “Start applet on session login.” Further, quit all the instances of PulseAudio Device Chooser that are in your SystemTray.](
(^^^ Click to see larger version)

Generally don’t uninstall PulseAudio as it may cause the loss of package dependencies that are easy to overlook. Post in the forum before doing that.

Have you installed any additional pulseaudio utilities after the main installation? The pulseaudio website considers some of those to be obsolete. PulseAudio Volume Control (pavucontrol) and PulseAudio Preferences (paprefs) are ok.

Dear Lord Emsworth,

Thanks for your reply. These pulseaudio applet icons are in the Task Bar, not System Tray. When I right click one of them and select Preferences, I saw the heading “PulseAudio Device Chooser” but the boxes, including " StartUp - start applet on session login", are not ticked at all. I would rather not remove pulseaudio because I spent lots of time getting it right so that I can hear audio on my USB headset instead of the system’s internal audio.

Hi everyone,

It must have been a case of “stuck keys” when I first installed “padevchooser”. The problem was solved by un-installing, reboot and re-installing this package. Thank you everyone, including and especially DenverD and consused, for your suggestions and comments.


Update: Problem returns! Oh well, perhaps I should ignore it.