openSUSE xfce live cd boot problem

Every single time i try to boot into the live desktop with xcfe, it fails to give me the desktop. I’ve used the failsafe version too, but it doesn’t help at all. When i boot in, it shows the loading bar, then a blue screen with the mouse pointer. I can move the pointer, but all i have is a blank, blue screen. I’m running this on a laptop with 639 mb of ram and a processor with 133mhz i believe. I have no problem running other distros with xfce (i’m running fedora xfce edition right now), but for some reason openSUSE just doesn’t want to work.

Hardware requirements - openSUSE

Not sure what xfce will give on that…

But did you do this:
http://dl.dropbox.com/u/10573557/Switcher%20Pics/media%20check.jpg

First, let me say WELCOME to openSUSE and WELCOME to openSUSE forums !!

There could be issues OTHER than just the incredibly slow processor. For example, what graphics hardware on this laptop ?

openSUSE has been around for a while. What version are you using ? 10.3 ? 11.0 ? 11.1. ? 11.2 ? 11.3 ? 11.4 milestone-x ? I’m sure this is obvious to you, but I can not tell. And yes, it might make a difference.

For example, if your hardware is an Intel i855 GM graphics, only 11.1 or earlier will boot. If your graphics is nvidia on 11.3, then you may need to specify the boot code ‘nomodeset’.

Perhaps you can help us here with a bit more information ? Thanks !

alright, caf, my hardware requirements meet the minimum and there is no “verify installation media” on the disk. it’s just the vanilla xfce live cd. not the dvd or anything.

oldcpu: the version is 11.3, and my graphics processor is an old Super Savage card. I can’t remember the model name and all, but it has like 16 mb of video memory if remember correctly. My laptop is an old IBM ThinkPad probably from 97 or 98. It’s in good condition and all. I have successfully booted, installed, and run for a few months the GNOME and lxde versions of openSUSE (both with 11.3). I’m very partial to xfce so i want it the most.

that should cover it. sorry for not being too in-depth in my first post. and thank you both for the swift replies ^-^

You can install xfce from the DVD and it has a text mode install if necessary

problem is i don’t have any dvds or a dvd burner to use. my technology available is very ancient lol. that’s what you get from cheap parents. i can see what i could do, but i’d like to try to troubleshoot the cd first and leave the dvd as a last resort.

If you could get an install to work, I would say open a terminal and type:

man savage

which explains the support for savage hardware, and that suggests to me you can configure your graphics for savage if it is not done automatically for you. But first before trying that, you need a basic functional install (which you don’t have).

You could try installing in a text mode from the liveCD. Please follow the guidance I provided here: Text mode install from liveCD

thanks. i’m installing as a type this, through the text mode installer (thank goodness for extra computers in the house). i’ll try that command after it’s done. just have one question, does that “man savage” require an internet connection?

No it is the savage help/manual page

Jim

thanks. ad it looks like the installation isn’t working either. it’s hung at 2% with removing the vol group of fedora i guess. maybe the xfce image is bad. i burned two cds though, and they both give me the same result. has anyone here done a successful install with the xfce cd? it would help me to know if it’s just me, or if the image itself is broken. i’m willing to think it’s my hardware, but i’f i’ve installed the GNOME and lxde editions perfectly fine, this should work too. usually i can do this stuff on my own, but this is just… odd

ok, the installation just hung at 2 percent for about an hour. for the time being, i’m going to use lxde. however, if anyone can get this problem solved, i would be very grateful. but thanks for all your help so far.

No one here can solve it, if you want attention of the developers you need to report the problem on bugzilla

If you installed Gnome for example - you can then install xfce and only use xfce, just add it from Yast software management
Patterns
http://dl.dropbox.com/u/10573557/Add%20Patterns/add-patterns-fromGTK.png

A failure at 2% is puzzling.

I’m wondering if your iso file that you downloaded was corrupted.

Referencing the ‘man savage’, as noted that was just a help/manual command. To actually apply the driver - one should first check to ensure it is not already in use. After a successful openSUSE install, one should look at the /var/log/Xorg.0.log file, and a read of that should indicate if the ‘savage’ driver is in use. I’m guessing, but I think one should see many lines with an entry like:
(**) SAVAGE
or
(==) SAVAGE

Now if one does not see that, but insteads see’s VESA or FBDEV in multiple places indicating one of those two graphic drivers are running, one can attempt to force the use of the SAVAGE driver by editing the /etc/X11/xorg.conf.d/50-device.conf file (with root permissions) so that it reads:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "savage"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

EndSection

then reboot and test. If the test causes the PC not to boot X window, then simply remove the edit.

I recommend the program ‘mc’ (midnight commander) be installed as it provides an excellent and easy to use editor for text mode.

In case the original poster’s still around:

What you’re seeing is TWM (tabbed window manager) instead of the Xfce desktop. (FWIW, hold down the left mouse button on the desktop and you’ll get a menu.) The current live Xfce CD, based on openSUSE 11.3, seems to be borked. See this thread.