openSUSE won't boot after update

Since doing an online update, I get these error messages when I try to load openSUSE 11.3;

Error: file not found
Error: you need to load the kernel first

For a couple of days, I’ve been getting notifications of updates, but when I’ve tried to install them, I’ve got warnings about unresolved dependencies. However, when I tried again yesterday, there were no warnings, and the update went straight through, so I assumed the problem had been sorted.

Apparently, I was wrong to think that.

Can anybody help, please?



Since my original post, I’ve realised that I’m not the only SUSE 11.3 user to have this problem. I’ve looked at the suggested solutions, but I can’t see how to apply them in my case.

If I knew which files to modify to use an earlier kernel, I know enough to be able to do that (Before Grub changed, I used to play with menu.lst quite happily, but since the change, I don’t know where to start.), so if some kind person could point me in the right direction, I can (probably) do the rest myself.


John Jones

Your original post states the problems went away and everything went fine. Are there issues? If not then accept the updated kernel and don’t try to downgrade.

Sorry, I obviously didn’t express myself as clearly as I thought I had.

My problem remains. As soon as I select openSUSE 11.3 from the Grub menu, I get 2 messages; -

Error: file not found
Error: you need to load the kernel first

My next keypress returns me to the Grub menu.

This happened after I did an online update. I have no idea how to go about getting my system working again. (I’m currently using Ubuntu.) Any suggestions would be gratefully received.


Whatever this kernel update was it was a dozy.

Can you start SUSE in failsafe mode? I’m hoping you have grub menu.lst error if that makes sense.

If not you should be able to read the SUSE partitions, but I advice against writing to SUSE, from the Ubuntu sessions. Mount the SUSE / readonly.

Pls post output from the /boot/grub/menu.lst found where ever you mounted the SUSE / (root) file between code and /code html tags each enclosed by brackets, ie, like


I updated to Kernel (desktop) using the online actualisation (Updater Applet). It installed the kernel OK, but the initrd seems to be broken: After a restart the PC got stuck just after “GRUB” and I landed in the mini-shell.
The kernel resp its initrd was not able to load from an ext4 root partition.
After lots of rebooting using the original kernel and checking … too long a story. Then I re-did the “initrd” just by running “mkinitrd” again, after that I was able to successfully boot again.
Did anybody have a similiar experience ? Is it possible that the official “initrd” of kernel is broken ?

AMD 64 X2 6000+

Hi Wizard741, when I try to boot, I don’t even get as far as a mini-shell, I just get bounced back to the Grub menu.

Hi tararpharazon, sorry for the delay in getting back to you; I’ve been giving my reply a lot of thought.

I’m actually booting through the Ubuntu Grub menu. When I installed openSUSE 11.3, my Ubuntu and my XP installations didn’t appear in the Grub menu, so I re-installed Ubuntu after which all my operating systems appeared in the Grub menu.

Presumably, this will change the situation from your point of view. Are you still able to help? I certainly hope so.


John Jones

You don’t need to reinstall. Just use the update-grub I believe this should look for all Linux kernels on the drive.

I ran update-grub in Ubuntu and since then I’ve been able to use SUSE. Presumably, the Ubuntu Grub hadn’t been updated after the online update I did on SUSE. Thanks for that. :slight_smile:

All I have to do now is figure out why I can’t use the Internet any more. It didn’t work after I originally installed SUSE, but I got it working eventually (can’t remember how, though). Now it’s not working again and I haven’t worked out how to fix the problem. Yet. :frowning:

Anyhoo, thanks for your help.



I did : Update from the updater applet this morning, reboot => I was dropped to the grub shell, no menu.
I booted the OpenSuse install CD in rescue mode, mounted the {boot,root} partitions : the /boot/grub/menu.lst was empty, but the menu.lst.old seemed OK. replacing the empty one by this one gave me back the grub menu on boot, but uncompressing the initrd failed miserably… Another boot in rescue mode later, I remounted/chrooted my root partition and was able to recreate the initrd file (mkinitrd) : everything back to normal… Like tararpharazon said, this update was a real ‘dozy’, to say the least :wink:



Congrats, phew that was a dozy of a problem. Very glad Gogalthorp provided the solution.
Before you post your network connection issue to the network/internet sub-forum check if Windows 7 and Ubuntu connects to the internet. That would at least narrow the replies to openSUSE.

The problem is definitely with SUSE; I’m using Ubuntu to post this, and I don’t use the Internet from Windows. I only keep the latter for anything I want to do that I can’t do in Linux, which means that these days I hardly ever use it.

I wasn’t really posting a request for help with my SUSE Internet access problem, just grousing. This is a problem I’ve never had with Ubuntu; all the peripherals just work.

I had trouble getting Internet access when I originally installed SUSE, but I got it working with a bit of poking and hoping, so hopefully, I’ll be able to to the same again, although I haven’t managed it so far. :’(

Thanks for your assistance, and if you do happen to know of an easy way to get my Internet access back, I’d love to hear about it.


*Sorry, thought it was an issue.

I’ve switched from the manual configuration to using Gnome NetworkManager to configure my internet access via its several options. Mine are wired to a wireless router but I also have a wireless Win7 connection.

I either enable DHCP or add a static IP address if DHCP fails until I get DHCP working again. So, much easier to click the icon on the panel and activate or edit the network connections. *

I have a netbook with OpenSuse 11.3 (gnome) on it; I added easypeasy (ubuntu derivative 2 days ago): OpenSuse prompted for an update install today; after that, I had the error message as posted above

error: you need to load the kernel first


sudo update-grub
that I found from this post

solved the issue and I can now boot into OpenSuse again;

The netbook has the RT3090 wireless card and it worked OOTB on this version of OpenSuse; so that was great; it is more flakey it seems in ubuntu; paradoxically mobile broadband is more tricky in OpenSuse; I have installed sakis3G to run the usb stick

Same problem here.
Error: file not found
Error: you need to load the kernel first
Tried update grub in Ultimate edition ,did not work.Then it came to me.Out of three os I am running had loaded mint last.
SUSE back to working,whew scary.Kudos for solution.