OpenSUSE with APC-UPS (uninterruptible power supply) device

Has anyone here used OpenSUSE with a UPS device? I just got one (a slightly older model) and I’m trying to set it up and have a few questions:

  1. It has an ethernet slot for controlling shutdown/data backup when the power goes out that it says needs a USB-RJ45 cable (USB-Ethernet). Has anyone gotten this to work with ethernet-to-ethernet instead?

  2. Any drivers I need to get it to work with OpenSUSE/Linux?

  3. Any instructions you can point me to for getting it to work with Linux?

Take a look at the HCL, might give you a hint.

6tr6tr schrieb:

>
> Has anyone here used OpenSUSE with a UPS device? I just got one (a
> slightly older model) and I’m trying to set it up and have a few
> questions:
>
> 1. It has an ethernet slot for controlling shutdown/data backup when
> the power goes out that it says needs a USB-RJ45 cable (USB-Ethernet).
> Has anyone gotten this to work with ethernet-to-ethernet instead?
>
> 2. Any drivers I need to get it to work with OpenSUSE/Linux?
>
> 3. Any instructions you can point me to for getting it to work with
> Linux?
>
>
One of my customers is running APC-UPC with SUSE 9.3, 10.2 and 10.3. IIRC
these machines are triggered thru the UPS network card.
Check apcupsd.org for further details http://tinyurl.com/f8rzt
Chris

6tr6tr wrote:

>
> Has anyone here used OpenSUSE with a UPS device? I just got one (a
> slightly older model) and I’m trying to set it up and have a few
> questions:
>
> 1. It has an ethernet slot for controlling shutdown/data backup when
> the power goes out that it says needs a USB-RJ45 cable (USB-Ethernet).
> Has anyone gotten this to work with ethernet-to-ethernet instead?
>
> 2. Any drivers I need to get it to work with OpenSUSE/Linux?
>
> 3. Any instructions you can point me to for getting it to work with
> Linux?
>
>
I’ve used various APC products, presently have a couple on my
systems. openSUSE 10.3 and 11.0 contain the APC RPMs on
the DVD.and probably one of the system repositories.

use Yast2 to install it. under Software Management → Type APC.
You should find the software and a GUI RPM. Some APC models
DO NOT support this software or do not have the capacilities built
in, so they only send a power off and on signal. The ES750 is one
that has the min. support mentioned. Most of the BACKUP PROs
and newer that support the APC CD supplied monitors will work
with the RPM versions. APC also has a download site that used
to have the Linux versions, I have not looked lately.

Hope this helps.

russbucket

Thanks!

Any idea if I have to use the USB-RJ45 cable as they say or has anyone here hooked it up successfully with RJ45-Rj45 (i.e. ethernet on both ends)?

On Tue October 21 2008 11:06 am, 6tr6tr wrote:

>
> Thanks!
>
> Any idea if I have to use the USB-RJ45 cable as they say or has anyone
> here hooked it up successfully with RJ45-Rj45 (i.e. ethernet on both
> ends)?
>
>
6tr6tr;

Check the connection type (UPSCABLE) in: /etc/apcupsd/apcupsd.conf. You may
need to adjust this. You can get documentation at: http://www.apcupsd.com/

P. V.
Cogito cogito ergo cogito sum.

On Mon, 2008-10-20 at 16:16 +0000, 6tr6tr wrote:
> Has anyone here used OpenSUSE with a UPS device? I just got one (a
> slightly older model) and I’m trying to set it up and have a few
> questions:
>
> 1. It has an ethernet slot for controlling shutdown/data backup when
> the power goes out that it says needs a USB-RJ45 cable (USB-Ethernet).
> Has anyone gotten this to work with ethernet-to-ethernet instead?

Only (few higher end old) models have ethernet. Most have
the USB to RJ45 (USB). It work though. I have the RS1000VA (aka
XS1000VA) connected to my desktop right now using that weird
USB to RJ45 (PROPRIETARY) cable from APC.

>
> 2. Any drivers I need to get it to work with OpenSUSE/Linux?

Just use the APC daemon that comes with openSUSE.

>
> 3. Any instructions you can point me to for getting it to work with
> Linux?

Works fine USB.

6tr6tr wrote:

>
> Thanks!
>
> Any idea if I have to use the USB-RJ45 cable as they say or has anyone
> here hooked it up successfully with RJ45-Rj45 (i.e. ethernet on both
> ends)?
>
>
I forgot to mention APC shipped me a special cable. They shipped it free of
charge. mine was a RJ45 to serial port. I ordered anew system and I do not
think it has a serial port. So I guess it would be nice if you find out the
answer and post it. Give APC support a call I have always found them
helpful.

Russ
Linux register user 441463
openSUSE11.0