OpenSUSE / Win 8 Boot Loader Problem

I am trying to install openSUSE 12.3 on a new Toshiba L70-A Laptop with Windows 8 pre-installed.

The installation (from downloaded DVD) goes smoothly until it is complete and the system boots for the first time. The boot screen does not appear and it boots to Windows 8 by default.

Please Advise.


Here are four big questions.

  1. Is this Laptop using Windows 8 Secure Boot?
  2. Is this a GPT Partitioned Hard Disk?
  3. Did you use the EFI boot selection in your UEFI PC setup to boot the openSUSE DVD disk?
  4. How did you get free space in which to load openSUSE?

For more info on Hard Disk partitions, Have a look here: Creating Partitions During Install for MBR and GPT Hard Disks - Blogs - openSUSE Forums

Thank You,

I suggest that you browse through the thread:
openSUSE/Windows8 dual boot installation Questions for Secure Boot, UEFI and GPT

It is a longish thread. It is about a similar problem with a different Toshiba. Pay particular attention starting at around comment 80. The next 20 comments or so are where the problem was solved.

I can’t guarantee that the same will work for you, but it might be worth a try.

I was hoping you would come to the rescue! I am proud to have scored 25% on the pop quiz with a sure answer only on #4. I’ll do whatever you say to bring my grade up.

The free space came during installation when it shrunk the Windows 8 partitions to give space (~470 gb on a 750 gb drive) for openSUSE 12.3.

I don’t know about Windows 8 Secure Boot or how to find out if I am using it.

I haven’t a clue what a GPT Partitioned Hard Disk is or how to find out whether I have one or not.

I used whatever boot selection was default during the installation. I didn’t pay much attention because I have Installed openSUSE on quite a few older machines and never had a problem. My mistake.

It is amazing how fast everything I know goes out of date. The past 18 months have been spent on family affairs, local politics and rebuilding my website. I come back and find I am a complete newcomer. I have been away from Windows even longer and Windows 8 looks like x-box or a smart phone instead of a computer. I am too old for this progress business. Stop the world and let me off!

Where do I start to get answers to your questions?


Before you do anything else, read through the hard disk partition link I provided and the message thread from nrickert. Mull through the information and then come back for more help. My guess it is using a GPT hard disk and you must go into your UEFI PC setup and select the EFI boot from the openSUSE DVD to properly install openSUSE. I can’t say about secure boot, but if you can not select EFI boot from the openSUSE DVD, it may be turned on.

Thank YOu,


I did not know I was going out on the bleeding edge again but there I am. After reading and thinking, I did several things that might make this thread useful to others:

[li]I downloaded KDE Live so I can get it running on the Toshiba L70-A laptop and answer any questions you might have from an openSUSE standpoint. It is running now - no problems except I have no internet access on that computer. I can copy to a thumb drive and carry it here if you want output from there.[/li][li]In the win 8 Desktop (not start screen), I found the “Toshiba Desktop Assist” which gives access to System Settings and the control panel.[/li][LIST]
[li]About all that can be done there is change the boot priority. I had previously changed it to boot from CD first to allow installation from the openSUSE 12.3 DVD.[/li][li]In the control panel I find that the BIOS Mode is UEFI, Secure Boot is on, the file system is NTFS and the Boot device is \Device\HarddiskVolume2.[/li][/ul]

[li]After booting from the Live CD, I went to YasT → System → Boot Loader and got the following error Message:[/li]“Because of Partitioning, the boot loader cannot be installed properly”.
[li]I still don’t know about the GPT partitioning or how the find out about it.[/li][/LIST]

What should I do next that will 1) help solve my problem and 2) provide useful information about the Toshiba L70-A for the experts here?


After reading that post over, there are several mistakes. First, change all “CD” to “DVD”. I don’t know why I keep calling them CDs.

I do know what GPT is and how it is suppose to work from reading the links.

I do not know whether this hard drive is GPT partitioned or not. I think it is but do not know how to verify it or what to do to get the boot loader to work.


Well with secure boot enabled, you must install openSUSE in EFI mode and using secure boot. More reading here:

Thank You,

If you can get us the output from:

# gdisk -l /dev/sda

that will provide the disk layout. We might then ask other questions.

I’m pretty sure that you have a UEFI system. The KDE live for opensuse 12.3 it a bit broken for UEFI systems. It can be used for install, but not with the installation defaults.

If you already tried installing from the live system, then the installer probably suggested a partitioning. It would be useful to know what partitioning it selected (or you selected), so we can advise what needs changing. Making hand notes, then posting them here should be sufficient for now.

Here is the output:

linux:/home/linux # gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1465149168 sectors, 698.6 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 3C7E2425-CD5D-11E2-B2CF-FD7E81217AAA
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1465149134
Partitions will be aligned on 2048-sector boundaries
Total free space is 4721 sectors (2.3 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 2099199 1024.0 MiB 2700 Basic data partition
2 2099200 2631679 260.0 MiB EF00 Basic data partition
3 2631680 2893823 128.0 MiB 0C01 Basic data partition
4 2893824 531319867 252.0 GiB 0700 Basic data partition
5 1443364864 1465147391 10.4 GiB 2700 Basic data partition
6 531320832 535527423 2.0 GiB 0700 primary
7 535527424 577472511 20.0 GiB 0700 primary
8 577472512 1443364863 412.9 GiB 0700 primary

I did NOT install from KDE Live DVD. I did the installation from the full DVD - TWICE.

If I remember correctly, the first installation only recommended 7 partitions. When the Boot Loader did not appear as usual, I did a second installation thinking something might have interrupted before first boot. Only then did I realize this was not the usual dual boot setup I had done several times before. That is when I asked for help here.

It is definitely a UEFI System. In the control panel (Win 8) I find that the BIOS Mode is UEFI, Secure Boot is on, the file system is NTFS and the Boot device is \Device\HarddiskVolume2.

I want to help so let me know what will be helpful to you and I will do it.


Good reading. I am learning a lot. The GPT and UEFI seem like true progress to accommodate bigger, faster and more reliable data storage.

Secure Boot?? Maybe I am paranoid but it seems like an effort on Microsoft’s part to review and approve any OS that is installed. Used in the open-source spirit of good will and cooperation, it could be a very good thing. But it could just as easily be used to stifle other operating systems and hinder competitors. I just don’t trust MS to do the right thing and suspect it is a step toward eliminating dual boot setups. With an enticing name like “Secure Boot” it is hard to turn it off (do I want insecure boots?)

Enough of that.

How do I go about correcting the installation I have or wiping it out and starting over?


Your EFI partition is “/dev/sda2”. I mention this for future note.

Can do the following while running the live KDE system:

# efibootmgr -v
# mount /dev/sda2 /mnt
# ls /mnt/EFI

If possible, post the output with “code” tags. You can click on the “#” at the top of the edit window to generate the code tags, then post the output between them. I took the liberty of adding code tags to part of what I quoted from your message. You can see that it is more readable that way (properly in columns).

I’m looking to see if your system installed properly, including the UEFI booting. It’s possible that the commands I requested will give errors. You can post the error messages in that case.

Do you have only the one disk drive on the system, or is there a second disk drive?

Here is the Output:

linux@linux:~> su
linux:/home/linux # efibootmgr -v
BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 2002,0005,0004,2003,2001
Boot0000* EFI DVD/CDROM (TSSTcorp CDDVDW SU-208BB)      ACPI(a0341d0,0)PCI(1f,2)03120a00040000000000CD-ROM(1,65,77039)RC
Boot0001* EFI Network 0 for IPv6 (08-9E-01-C6-82-17)    ACPI(a0341d0,0)PCI(1c,3)PCI(0,0)MAC(089e01c68217,0)030d3c000000000000000000000000000000000000000000000000000000000000000000000000000000004000000000000000000000000000000000RC
Boot0002* EFI Network 0 for IPv4 (08-9E-01-C6-82-17)    ACPI(a0341d0,0)PCI(1c,3)PCI(0,0)MAC(089e01c68217,0)IPv4(<->,0, 0RC
Boot0003* Windows Boot Manager  HD(2,200800,82000,eb6d9da5-a2f9-11e2-9bde-88a01d4792bf)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0004* Windows Boot Manager  HD(2,200800,82000,3c7e242e-cd5d-11e2-b2cf-fd7e81217aaa)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0005* opensuse      HD(2,200800,82000,3c7e242e-cd5d-11e2-b2cf-fd7e81217aaa)File(\EFI\opensuse\grubx64.efi)
Boot2001* EFI USB Device        RC
Boot2003* EFI Network   RC
linux:/home/linux # mount /dev/sda2 /mnt
linux:/home/linux # ls /mnt/EFI
Boot  Microsoft  opensuse  toshiba
linux:/home/linux # ^C
linux:/home/linux # 

There is only one hard drive. Plus of course the dvd running live KD and the thumb drive I am using to shuttle commands and output between computers.

Okay so far.

A little puzzle, is that I am not seeing a linux partition. Usually, when I install, the partition type code is changed to 83. For a GPT disk, that would be 8300. But perhaps that type code change doesn’t work on GPT. So I’ll assume that linux is on one or more of those partitions with type code 0700.

The “efibootmgr” output and the “ls” command output look good.

Your linux was not installed to use secure-boot. If you have not yet done so, try getting into your BIOS setup and disabling secure boot. And then, try again at booting. There should be a way of getting a BIOS boot menu, possibly hitting F12 during boot. See if there is an option for opensuse there. Until secure-boot is disabled, that option won’t probably show up.

After some experimenting, I find that F2 goes to the BIOS setup on the Toshiba L70-A. The utility they use is called InsydeH20 Setup Utility Rev 3.7 if that little tidbit is of any use to anyone.

Secure Boot can be disabled under the security tab. I disabled it. There was no opensuse entry under Boot.

I set it to rebooting to live KD since that takes some time. I will reboot again and use F2 or F12 to see if there are any opensuse entries and report back shortly.


Sorry to be so slow. My grand daughter caught a tiny lizard and put it in the bathtub for observation which freaked out my wife. Calm is restored.

There is no reference to opensuse anywhere in the BIOS setup or BIOS Boot (using F12) that I can find. Secure Boot is disabled.

What next?


The options under Boot are:
ODD - showing the optical drive modle etc
HDD/SSD showing the Toshiba Hard drive
LAN showing EFI Network 0 for IPv4
USB with no options


I wonder what the first Windows entry points to. Are there multiple disks in this system?


Is there anything I can do to provide information?


That puzzled me, too.