OpenSuse will not boot

My mom got a new computer and she said I could do whatever I wanted with it. I’ve decided to try out some distros of linux, and it currently has ubuntu on it. I heard OpenSuse was much faster and would run better on this older system, so I’ve tried to boot it but no luck. When the computer turns on, it’s set to boot from CD but “GRUB” just pops up in a console-like text and then disappears. Then after that it’s just the Ubuntu logo and startup continues normally.

Either the CD is NOT set as boot device or you burned the CD incorrectly. If you read the contents of the CD you burned in ubuntu - what do you see - how many files and folders? Remember too, you must burn CD’s as slow as you possibly can.

These are the files on the CD.
After burning, I verified the burn and it works properly when booting on windows.

Is there something wrong with the CD? I don’t know what I could possibly be doing wrong. I know the computer is set to boot from CD, “GRUB Loading” comes up but it just cancels and starts up Ubuntu after a few seconds.

No, if you see GRUB loading, it’s booting from the HD. It should say something like ISOLINUX, which is the bootloader on the CD. The CD LED should flash to show that it’s being accessed.

Double check your BIOS settings. And you may have a faulty CD drive.

I can only agree with @Ken_Yap

Double check your bios settings because at the moment you are booting from the HD, unless the CD drive is faulty, but that seems unlikely as you just posted info from it in that image.
The contents of the cd look OK though.

I feel gloriously retarded. It’s an old computer and probably just does not support DVD, Ubuntu came on a CD so that’s probably why that worked and this didn’t. I guess I’ll have to install by Network, sorry for wasting your time

You can get the LiveCD. Inspite of the name, you can choose to install right away without going through the LiveCD, which might be problematic if you don’t have enough RAM (like 1GB) for the LiveCD but enough (like > 512MB) for a disk install.

Thanks for the tip, that’ll be much simpler. I think it has 1GB of ram.