openSUSE Update 2015-42 Issues

For the record, I am running openSUSE 13.2 with Linux kernel 3.16 and KDE 4.14.2. Recently I ran a check for system updates using KDE’s system tray software updater and found only one outstanding update, which was and is the one mentioned in the title of this post. Seeing as it included various minor but useful fixes and updates for zypper and libzypp, I decided to install it. However, when I attempted to do just that, I was presented with this message. When I attempted to install the same update in YaST Online Update, I was presented with the same warning as well as the three options shown in this screenshot. At this point, since I do not consider removing every last package-management-related front, middle and back end on my system to be a solution, I clicked cancel. What I am unsure of, however, is what to do next. As far as I can tell, the problem is that the openSUSE front end for PackageKit has a new version available in the openSUSE repositories, but PackageKit itself does not. Please correct me if I’m wrong. What would be the best way around this, or should I just ignore the update? Thanks!

a list of your repositories might be helpful
zypper lr -u
something similar has happened to me when using some extra repo’s

That’s wrong.
The frontend doesn’t know anything about available packages. It just displays what PackageKit tells it (which is the available update) and then calls PackageKit to install that update.

So it is PackageKit itself (and YaST too, which has absolutely no relation to the desktop’s updater) that doesn’t find an installable PackageKit-1.0.3 in any repo.
PackageKit-1.0.3 is available in the standard update repo. So please, do as I_A asked and post your repo list. But please post the output of “zypper lr -d” instead, this will contain all details.

OTOH, YaST’s message says:

nothing provides PackageKit = 1.0.3 needed by PackageKit-branding-openSUSE-13.2-2.7.1.noarch

Conflict Resolution:
() 1: Following actions will be done:
deinstallation of PackageKit-branding-openSUSE-13.2-2.2.1.noarch
deinstallation of PackageKit-1.0.0-4.1.x86_64
deinstallation of apper-0.9.1-2.1.x86_64
deinstallation of PackageKit-backend-zypp-1.0.0-4.1.x86_64

Notice that it wants to deinstall the old versions (PackageKit 1.0.0), because it cannot install 1.0.3 otherwise which is needed by the new PackageKit-branding-openSUSE-13.2-2.7.1
The reason for this might be that you installed PackageKit from some extra repo.

IMHO, choosing solution 1 would just do the right thing: remove the old PackageKit versions and install the updated packages.
You can verify what will be done on YaST’s “Installation Summary” view, before clicking “Accept” and really changing anything on your system.

Sorry I took so long! As requested:

I checked the installation summary in YaST, and all option 1 does is delete those 4 packages.

Why is the update repo turned off???

Not only that, there’s also another repo that is not intended at all for an x86 system: [noparse]openSUSE:ports:update[/noparse] (#8)
It’s probably this where PackageKit finds the update, but it cannot install the packages because they have the wrong architecture (ARM and PPC).

So enable the former and remove the latter. I.e. run this, and the updates should be installable:

sudo zypper rr 8
sudo zypper mr -e 2

Without the (right) update repo active, the updates cannot be found and installed of course.

Well that worked. I had no idea that the main update repo was turned off, and I had no time to actually examine the list of repositories I uploaded. I never understood what #8 was for though. Thanks for your help!

Well, “openSUSE:Ports” is the port of openSUSE to other CPU architectures like ARM or PPC.
And #8 is the update repo for that.

Normally you shouldn’t have it. But AFAIK there are some repos on OBS that are a bit misconfigured, if you install a package from them via the 1-click install, that repo will be added by mistake.