OpenSUSE - two installs, two consecutive days, same computer, different outcome

Hi,

I installed oST yesterday but accidentally uninstalled/borked the entire DE (weird accident - still don’t understand what happened). Anyway, for other reasons, too, I did a clean install to start over.[FONT=arial]
[/FONT]
[FONT=arial]The first time, I did the guided partition setup because I adidn’t want to use the swap from my other SSD, as I likely won’t keep it (oST detected the swap from that previous install on that other SSD). It did the automatic portion as:[/FONT][FONT=arial]
[/FONT]
[FONT=arial]8mb boot[/FONT]
[FONT=arial]462gb / and /home[/FONT]
[FONT=arial]16gb swap[/FONT]
[FONT=arial]Standard boot[/FONT][FONT=arial]
[/FONT]
[FONT=arial]Today, using the same computer to install, same SSD, same exact USB, iso, and snapshot, I got this outcome:[/FONT][FONT=arial]
[/FONT]
[FONT=arial]500mb boot[/FONT]
[FONT=arial]461gb / and /home [/FONT]
[FONT=arial]16gb swap (I wanted to use less but couldn’t get it to let me use less without the oST installer trying to map swap over to the one on my other SSD) [/FONT]
[FONT=arial]Secure boot[/FONT][FONT=arial]
[/FONT]
[FONT=arial]I just thought this was odd. I made no changes, it just made different decisions using the same iso, USB, snapshot, and computer/SSD. I found it strange that one day it used 8mb boot the next day 500mb. The odd thing is that the 8mb was enough for boot. Also, the boot is completely different than yesterday. Previously, my bios still had the old SSD booting first (still does, as I haven’t changed it yet) but not oST is taking over and its grub menu is what comes up first, rather than the other SSD. Obviously, I was going to move the oST SSD into the first boot position, once I get everything setup and moved over but I just don’t understand why and how the two identical installs ended up with such different outcomes. Everything from the partitions to the boot/grub, secure boot (I didn’t make any changes to this either time from the default), etc. Why would this be? Why did the grub menu change today vs yesterday? Why did the boot partition increase by more than 6x? Any info and thoughts would be brilliant. I’m just really intrigued and stumped as to what happened and why. Thanks in advance![/FONT]

First time you performed legacy BIOS boot, second time EFI boot.

I compare installing and maintaining Linux systems to driving a car:

  • You need a driver’s license, but you need some practice too.
  • You need an image file, but you need some practice too.

For newer hardware experience has shown the following furthers smooth install and maintenance:

  • Make sure your mainboard firmware is up to date.
  • Reset mainboard settings to defaults, turn off compatibility support module and select USB stick from the boot menu of the mainboard.
  • With Yast installer turn off secure boot and select expert partitioner. Mount or create an EFI System Partition, a Linux System partition and a /home partition

Applied the above to Leap 15.2 and succeeded in less than 10 minutes: https://karlmistelberger.wordpress.com/2020/07/02/opensuse-leap-15-2/

@arvidjaar, That’s amazing. I think that is exactly what happened. I tried to do the same legacy boot that I remembered doing the first time when I went to reinstall today but each time, it got hung up on the green bar across the bottom of the screen. I waited 30+ minutes each time and it was still stuck. I tried rebooting and waiting at least two or three times with the same results (still don’t understand why that happened, either). So, I decided to try the UEFI and it booted right up and installed without a hitch. It never even remotely occurred to me that booting in two different ways would bring about two completely different installs.

Moving forward, is one better than another? Before I setup everything tomorrow, do I need to do the legacy boot reinstall (again) or is the UEFI the better way to go on modern hardware anyway?

Thanks so much for explaining it! I really love to find a reason for something happening. It helps my brain make sense of the perceived chaos. :slight_smile:

With UEFI, you need an EFI partition (that 500M partition) for the booting. The difference in the installs is mainly that, with a corresponding small difference in how booting is installed.

Moving forward, is one better than another? Before I setup everything tomorrow, do I need to do the legacy boot reinstall (again) or is the UEFI the better way to go on modern hardware anyway?

In my opinion, UEFI is the better way for modern hardware.

Maybe.
Or, IMO more likely is that the original 8MB boot partition wasn’t removed and the new install detected its existence, silently offering to use it as part of your install.
IMO it’s unlikely that the system would switch from UEFI to legacy MBR without a BIOS setting change.

A common mistake when re-installing for using previously used disks is to not remove <every> partition when installing new again.

Wipe that disk completely!
And then, you can be sure you won’t experience surprises.

TSU

When challenged remove all disks. Use a new inexpensive SSD. When comfortable with the procedures put everything together again.