openSUSE Tumbleweed new user not being offered 3.6 kernel during zypper dup

Hello. The title says it all.

I have done two clean installs updated patches and rebooted and re-aligned repos to Tumbleweed and then run zypper dup.

This has been a struggle over the past couple of days and it is documented on this thread:

If anyone wishes to help or shed light on why my zypper dup does not see or install the new kernel - 3.6 series I believe - then please read backwards from where my helper caf4926 has advised me to start a new thread here.

Here are my repos:

zypper lr -d
# | Alias               | Name                | Enabled | Refresh | Priority | Type   | URI                                                                      | Service
1 | repo-non-oss        | repo-non-oss        | Yes     | Yes     |   99     | yast2  | |        
2 | repo-oss            | repo-oss            | Yes     | Yes     |   99     | yast2  |     |        
3 | repo-update         | repo-update         | Yes     | Yes     |   99     | rpm-md |                    |        
4 | repo-update-non-oss | repo-update-non-oss | Yes     | Yes     |   99     | rpm-md |            |        
5 | tumbleweed          | tumbleweed          | Yes     | Yes     |   99     | rpm-md | |        

and here is the output of uname -r:

uname -r

What else would you need to know?
The installs were made from openSUSE12.2 CD ISO
The desktop environment is KDE

Thank you kindly,


On 10/09/2012 06:56 AM, folkpuddle wrote:
> If anyone wishes to help or shed light on why my zypper dup does not
> see or install the new kernel - 3.6

sorry, i don’t wish to read back through 50+ posts to learn: what kernel
are you now running? the first line below a terminal will tell that and
what kernels do you now have installed will be told by the second?

uname -a
ls -h /boot | grep vm | grep gz

please copy paste both results back into code tags, as described here:


When you use zypper dup as root, a safe way is:

sudo zypper dup --from 5

from your repos you list.

On 10/09/2012 12:16 PM, douglarek wrote:
> sudo zypper

as far as i know zypper should not be run by sudo.


Why not?, I haven’t seen a problem with it.

Like already said here, running “zypper dup” just like that is not going to bring you to Tumbleweed. You have to tell zypper it has to make a “vendor change” to Tumbleweed, so in your case

su -c 'zypper dup --from tumbleweed'

if this makes you run into dependency conflcts, please post the output of the command above here, between CODE tags.

On 10/09/2012 02:16 PM, consused wrote:
> Why not?, I haven’t seen a problem with it.

sudo runs with the environment and path of the user who invokes sudo…

and YaST Software Management and Online Update both run with roots
environment/path, so it seems to me that zypper should be run by root,
with roots environment and path…

you may “get away with” running (zypper) installs with a users path
(because, i guess the rpms should know where to push stuff to), but you
should expect a failure if you run “make install” without roots


Thanks, will try to remember if/when. :slight_smile:

Thanks for that - you and the other poster who proposed using the --from tumbleweed.

There were dependencies but I was able to solve them quickly. I have had much experience over the last 72 hours.

This is what I wished to see:

uname -a
Linux linux-8l9b 3.6.0-3-desktop #1 SMP PREEMPT Wed Oct 3 12:00:23 UTC 2012 (630c86a) x86_64 x86_64 x86_64 GNU/Linux

One more thing: will I always have to

zypper dup --from tumbleweed

from now on?

Best wishes,


That’s a question that can’t be answerwd with a yes / no. What you do with a 'zypper dup --from repoX " is tell the system that you want installed packages to be the versions from repoX. This goes for currently installed packages, and since the Tumbleweed repo has just started being populated, you may need to do this more often. But, by the time the Tumbleweed has most of the packages you use installed a " zypper up " is fine.

If you’re new to this, I strongly suggest you use Yast’s softwaremanagement. The repo view mode allows you to see which packages live in which repo.

BTW: nice to read you got it sorted

Just one more thing: I suddenly notice the “new user” in the thread title. You’re on your way now, but I wouldn’t suggest Tumbleweed to a new user. 'Latest and greatest" is not always the best way to go, if you’re just starting you’ll find a much larger crowd to support you when you stick to the distro’s version.
A couple of tips:

  • keep your number of repos limited to oss, non-oss, their update sisters and packman. That should keep you out of trouble
  • invest some time of your own to fix things instead of reinstalling.
  • be patient, the forums are run by volunteers that have daily jobs, families and do on, some things need specialist’s advice
  • enjoy

The ‘new user’ refers to my status as new user of this iteration of openSUSE and Tumbleweed.
My use of ‘new user’ in the title might also explain why people were keen to explain how to use code tags - this is puzzling as the first post contained two (2) examples of the use of code tags.
Likewise it would not occur to me to use ‘sudo’ - but a presumed ‘new user’ might not know that e.g. a *buntu refugee
<<invest some time of your own to fix things instead of reinstalling.>> - with all dues respect three days of fiddling went nowhere in this instance. I could afford the bandwidth allowance this month,
it was no trouble to reinstall.
When you live in the Southern Hemisphere like I do the timezone factor teaches this linuxer to be patient - I am asleep when folks are replying!! and vice versa,

Best wishes and much thanks,


To make it clear.

zypper dup

should update the entire system


zypper dup -r tumbleweed

is not the same as

zypper dup

And by itself, it would not get you a complete update

I again did a clean install, and recorded it here:

And FYI:

zypper dup

Is the recommended update method for using tumbleweed

The yast method
Is basically the same as ‘dup’, but only if you haven’t applied any repo switches. Once you do that, this method will hold updates to the switches.

Hence in Tumbleweed I just use

zypper dup

If I need the Packman switch, I re-apply that after any ‘dup’

I updated two PCs to 12.2-Tumbleweed using ‘zypper dup’ (where both PCs had 12.1 Tumbleweed prior to the update). Both worked. Both were old PCs (one my Sandbox PC with an Athlon-1100 CPU and 2GB of RAM, and the other an old office laptop with 1.6GHz Intel CPU with 512MB RAM). Both updates took a long time ~2 hours in one case and ~2.5 hours in the other, and I have a very fast Internet connection. I had solve one dependency (different) in each case. The dependencies were different and not difficult to solve (each associated with a packman packaged multimedia app). The repositories I had in place were the openSUSE-current OSS, openSUSE-current Non-Oss, openSUSE-current update, the standard tumbleweed, and the Packman Tumbleweed.

I’m still not ready to update my main PC this way (I prefer the cleaning that comes with a re-install) but I confess to being impressed with the ease of doing a ‘zypper dup’. I can see it being the way of the future (for me) for updates.

You got the point; but as Knurpht said above: if your number of repos limited to oss, non-oss, their update sisters and packman, you can do it with zypper dup.

Anyway, using zypper dup --from tumbleweed is a safe way which leads you little trouble:P

Anyway, using zypper dup --from tumbleweed is a safe way which leads you little trouble:P
If you say so

But it’ll not fetch in updates from the other repos will it

But it’ll not fetch in updates from the other repos will it

I think you got misunderstand here. take gstreamer-0_10-plugins-good for example: it is in openSUSE Current oss,but in sometime there is a higher version in Packman,it will not update automatically util you execute zypper dup --from packman,is not it?

as you said dup means to get latest version in current repos,but dup --from tumbleweed is just a Friendly suggestion(Portal:Tumbleweed - openSUSE):stuck_out_tongue:

I said
zypper dup

Use the switcher on Packman if you need to after each update with ‘dup’
But you must do what suits you

We are now: 3.6.1-4-desktop

Yeah, we all are 3.6.1-4-desktop who uses Tumbleweed now :stuck_out_tongue:

Fascinating as this debate about zypper dup and/or zypper dup --from tumbleweed, we must not lose sight of why I started the new thread.
As you know from spending all that virtual time with me yesterday zypper dup on a complete new patched install did not do the business as far as bringing in the new kernel.
While my zypper dup was failing your zypper dup was succeeding.
Neither of us knows why. It has never happened to me before. openSUSE12.1 for example was converted or translated to Tumbleweed by me earlier this year.

I started this new thread I was advised to try zypper dup --from tumbleweed and it was successful.

Now how can I argue with a result like that? I can’t and won’t.

Best wishes,