openSUSE Tumbleweed KDE 64Bit To Android SmartPhone File Transfer Over USB Not Working Correctly?


I am running openSUSE Tumbleweed KDE 64Bit on a custom desktop.
I am trying to copy over alot of files from Tumbleweed to my Android smartphone.
SmartPhone is recognized by Tumbleweed but the USB file transfer starts and stalls?
(smartphone is an old Samsung Galaxy S7 Edge with Android OS version 8.0.0)

Any ideas?
Let me know, thanks!




the transfer of files and listing of directories, appear sensitive to the usb cable used. On this pc (Ryzen 3), using the usb connection direct to the mainboard, only works with some cables.
Newer slightly thinner ones.

Connections via 3/4 port usb-hubs that have been tried also do not work.

It was trial and error finding a cable that worked.

Once the right cable was found the connection was rock solid


I don’t know how well Samsung handles ADB (Android Debug Bridge) connections, but I recommend trying it. ADB needs to be set up once to ensure a secure connection. After that, it’s easy, especially if you repeat the same ADB commands from previous ADB connections (I use my bash history for that).

Frequent ADB commands I use:

*# After plugging the USB cable between my openSUSE Leap machine and my Moto G, activating »USB debugging« in its Developer Options: test if my Android device is connected via ADB:*
adb devices

*# dump information about the phone battery and charging details:*
adb shell cat /sys/class/rtc/rtc0/since_epoch /sys/class/power_supply/battery/status /sys/class/power_supply/battery/health /sys/class/power_supply/battery/capacity

*# List all movies and images made with the phone’s camera:*
adb shell **ls -l **"/mnt/shell/emulated/0/DCIM/Camera/"

*# Just a few days ago: get (adb lingo: »pull«) any photos made in April 2020*
adb shell **find** "/mnt" -iname "img_202004*.jpg" | tr -d '\015' | grep -v ': Permission denied' | while read f; do **adb pull** $f; done

*# Pull any text files written on my phone, usually written with the Lesser Pad app from the FDroid store:*
adb shell find "/mnt" -iname "*.txt" | tr -d '\015' | while read f; do adb pull "$f"; done

*# Put a few bits of music from my openSUSE Leap box on the phone:*
adb **push** *.mp3 /sdcard/Music/

*# Install a few new app versions manually, because yes, I'm that paranoid, also frugal with mobile data:*
adb install com.danielkim.soundrecorder_130.apk
adb install FDroid.apk
adb install
adb install
adb install com.vonglasow.michael.satstat_3030.apk

*# When the phone is charged, all files pushed and pulled, and all is done: *
adb kill-server
*# … then disable »USB debugging« in the phone's Developer Options again, and unplug. *

The possibilities are infinite.

After transferring files to and from my device the follows has been observed.

Access to the Android device is more probable if,

  1. File manage is not active when usb connection is made

  2. File manage is not active when file transfer is enabled on the Android device

  3. File manager is activated only after the above two steps


I have used adb quite extensively but if I’m just quickly transferring files I just plug in the usb cable. The phone shows up in dolphin, I open a 2nd pane for the pc/laptop and drag and drop files from one way to the other.

Why not use KDEconnect? These days it’s installed by default. Just open it’s ports in the firewall, install the app on your Android phone, pair the phone and your computer, and Dolphin will show the phone’s storage and allow you to transfer files from and to the phone.

I couldn’t get kde connect to work when I tried. That was quite a long time ago and I probably was doing something wrong but I find dolphin easiest.
Of course, if you’re not using KDE it may not work as well. I don’t know.

I had KDEconnect running on GNOME and that worked to a certain extent. Not with Nautilus IIRC.

Most important is to adjust the firewall. When that’s done and phone and computer are on the same network, it just works.