openSUSE tumbleweed: How I rescued Plymouth

Added to Yast Repositories:
Then in Yast Software Management, you type Plymouth, and all that is related to it (libply-boot-client4, libply-splash-core4, libply-splash-graphics4, libply4, plymouth, plymouth-dracut, plymouth-plugin-label-ft , plymouth-plugin-script, plymouth-scripts), installing versions 0.9.2-4.1 from the above-mentioned repositories.
Then you type mkinitrd into Terminal, then reboot.

Afterwards, the above installed packages in Yast label: Protected - Do Not Modify.
Then, you can turn off the above Repositories (mrbadguy).
And that is it!
You will no longer have a gray background and three green dice, but a nice new Plymouth.
I was installed nVidia drivers from the official nVidia Tumbleweed Repositories.

Sorry for my Google Translate English
I hope I helped you

Thanks for posting - I will give that a go tonight.

That’s an OSB user’s homedir. These repos are experimental, and things will break, since that is what these repos are for: a place to break things. Use at your own risk.

Version 0.9.2-4.1 of these applications was previously in regular repositories, when Plymouth worked. These new versions have led to Plymouth not working. The situation is the same with Leap.
Also, all these applications with version 0.9.2-4.1 can be put into their own Local Repo. Priority 50.
Will there ever be a problem?

Worked fine for me. Thanks very much for the tip.

At some point other packages required by this version may be updated requiring this version rebuild (and this is not even possible in this repository, plymouth has not been built for over a year). Then the only choice will be to remove it.

If someone can reliably reproduce the problem on version update it would be really helpful to do bisect to find out exact commit that caused it.

I have heard that there is work on the code for kernel 4.17 and higher so that the bootsplash will be added to the kernel.
Therefore Plymouth will no longer be required. Yes SUSE stopped working on the mainline kernel but openSUSE will be working on it.

This I heard on the openSUSE Factory ML.

Has anyone tried yet?
Whether it works?

Plymouth does not work in any way with the Nvidia drivers installed. Of this I’m never worried, but if it works it would be nice

Try it. Three minutes of work.

I ‘ve tried it, that’ s why I posted, I have already traveled on other occasions, following various guides, but I never succeeded.
Among other things, my boot lasts 9 -10 seconds in all, so sometimes you can see … but do not have time to login

It’s great if that works, but does anyone know WHY it works and what stops it working with the normal Plymouth?

I’ve got a machine using the Intel chip for graphics where Plymouth works and an nVidia machine that doesn’t (despite following “here’s how to make it work on nVidia” tutorials). It’d be nice to be able to fix it properly.

It still works, without problems!

It’s great that it works, but does anyone know WHY it works and what stops it working with the normal Plymouth?

The only way we’ll be able resolve this problem is to submit a bug report.
IMO They need to bisect the working one in Leap 42.3 - plymouth 0.9.2-6.1 and plymouth 9.3GITx.

It’s important that this type of software be tested on real hardware instead of testing plymouth virtually.
Now the problem has become more complex. It could be an issue with dracut, the kernel, plymouth, the nvidia drivers or all of the above.

I would encourage openSUSE to continue where SUSE has left off by adding the bootsplash to the kernel like in MacOS and Windows.