OpenSuse Tumbleweed fails to boot after installation on MAC (Frozen blank screen)

Ok, I just retried a fresh install of Tumbleweed on Macbook PRO 2009, and it fails to boot. (The first time I tried this, it turned out that I created the USB with the wrong image).
However, I complete the install from the correct image and then reboot. The EFI Boot manager is available and I can select Tumbleweed to boot. So it progresses and finally and blue-ish screen appears (actually, its the OpenSuse background picture), I have a mouse pointer, but nothing else. The UI fails to load properly and there is no prompt to login.

I have tried re-installing the bootloader according to ( Modifying and Re-installing the Boot Loader), but this has made no difference.

Section “17.2.2 No Login or Prompt Appears” in the link above, seems like it is the most appropriate course of action to take, but then reading it, seems to be trying to fix a kernel problem caused by an upgrade of the kernel. This is not my scenario since I’m just trying to do a fresh install rather than an upgrade.

I don’t know what to do now, so assistance would be be appreciated,


Maybe a NVIDIA issue. try booting with nomodeset

At grub boot press e find line starting linuxefi go to the end of the line (note it wraps) add a space and nomdeset F10 to continue boot

You may need to add the NVIDIA driver but not sure of support on 9400M GPU now.

Hi and thanks. You have referred to “nomodeset” and “nomdeset”. Which is the correct one I should use to edit that file with from the e option you say?

I’ve tried the installation both with nvidia driver that you are warned about and with the emulator that is suggested as an alternative. Both are just as ineffective in solving this.

OOPS nomodeset it should use fall back drivers

Ok thanks. Now that has made a huge difference. I now get a title bar with activities on the left the time in the middle and some icons on the right. This at least is something. However, I just rebooted to try and ensure that everything is ok, but its back to square 1 where it doesnt boot properly. Surely that edit that you told me to make doesnt have to be made every time I boot up??

The edit I suggested is not permanent. You must change the grub settings if you want to always use nomodeset. Easiest way is in Yast-bootloader section. But, the fallback drivers are not great and normally just used until you can fix the underlying problem. Not sure that the current NVIDIA drivers support the old 9400 chips and the old drivers may not work with the current kernels. They may need patching or may not work at all.

Nothing wrong with the fall back drivers except they are slow (no hardware acceleration) and low resolution.