openSUSE Tumbleweed + 15.2 automatically downloads after installation without asking the user

Hello,

I have reinstalled openSUSE 15.2 (GNOME) on an empty hard disk.

I took this ISO file.
http://download.opensuse.org/distribution/leap/15.2/iso/openSUSE-Leap-15.2-DVD-x86_64.iso

After the installation, I didn’t set anything, nothing opened or install anything and connected to my Wi-Fi network normally and something was loaded in background immediately. More than 50 MB and sometimes over 100 MB.

It seems that the first time I use it, it automatically connects to the background server to keep the packages up to date or something like that.

But the fact is that I tried it several times. That means again openSUSE 15.2 or the current openSUSE Tumbleweed (August 06, 2020) installed on an empty hard drive and connected to the Wi-Fi network normally and immediately downloaded in background.

For comparison, I have also tested other Linux distributions, like Fedora 32 and Manjaro 20.0.3, which have the same problem.

The only Linux distributions I have tested that don’t download anything automatically after installation is KDE neon August 06, 2020 and Solus 4.1.

I think this is a bug openSUSE developer.

The problem is that it has used up my data plan from the SIM card, because it downloads automatically after the installation. Please openSUSE, Fedora and Manjora developers fix it. It must not automatically download after the installation of the user, for example when the user connects to a Wi-Fi network.

Welcome to openSUSE and to the Forums!

Not sure of what you witnessed, but this looks as normal behaviour. That download seems like the repository data describing what packages are available online.
As installed out of the box there are a few repositories enabled and they are set to automatically refresh, either when you start YaST2-Software (the openSUSE package management application) or PackageKit, which is automatically
started at boot. If PackageKit finds that updates are available online, it asks whether you want to actually download and install or not.
If you don’t like that behaviour, you should install offline (without a network connection), then open YaST Software repositories and untick “Automatically Refresh” for all listed repositories, then possibly uninstall PackageKit.
That way you should be able to connect to a network and refresh-download only when you choose to do so.

But the fact is that I tried it several times. That means again openSUSE 15.2 or the current openSUSE Tumbleweed (August 06, 2020) installed on an empty hard drive and connected to the Wi-Fi network normally and immediately downloaded in background.

I think this is a bug openSUSE developer.

The problem is that it has used up my data plan from the SIM card, because it downloads automatically after the installation. Please openSUSE, Fedora and Manjora developers fix it. It must not automatically download after the installation of the user, for example when the user connects to a Wi-Fi network.

I understand your problem, but I don’t think this is a bug and it is unlikely that developers understand that as a bug. Anyway, this is a user forum and not a direct link to developers.
If you really want a developer to look at your problem you should submit a bug report at Bugzilla Main Page (same username and password as used to access this Forum).

I use KDE here.

When I login, it would normally download the repo metadata (information about updates available). That’s maybe 2 megabytes (I’m guessing). My normal practice is to turn that off, by disabling the update applet.

I sometimes play with Gnome. And with Gnome, the default seems to be to download the repo metadata, and then to download all of the needed update packages (the ‘rpm’ files). It does not install them. I think it prompts to install on the next shutdown/reboot.

I also disable that practice (the downloading of rpm files). I disable with dconf-editor, but it isn’t obvious where to find that. I have not found how to disable the download of the metadata – I suspect that it cannot be disabled except by uninstalling “packagekit”.

I’m using Gnome here. Just done a “zypper ref” and the system downloaded some 30 MB just for the “OSS-update” repo, consistent with what the OP witnessed.

I did admit that I was guessing about the size of the metadata.

After Gnome has done it’s thing, try:

zypper up -D

That won’t do anything (because of the “-D”). But look to see if it says that the updates are in cache.

If the OP tries this, I’m guessing that there will be updates in cache.

Confirming that after the update applet has informed me that “important updates are available” there are a few packages already in the cache, apparently downloaded in background.
I found no way to change that behaviour, other than uninstalling PackageKit.
So no wonder the OP sees some 100 MB of background downloads right after an offline install.

dconf Editor /org/gnome/software/download-updates

and you can turn that off. But I have not found how to turn off the repo refresh, except by uninstalling packagekit.

And, yes, I suspect that was what the OP was seeing.

Thanks for the hint.
I also found dconf Editor /org/gnome/software/refresh-when-metered and that should be OFF by default.
BUT you have to set your connection as “metered”.
Open a terminal and issue:

su -
<enter root password>
nmcli connection show

to show the list of connections known to the system. Say that you want to set connection MyWiFi as “metered”.

nmcli connection edit MyWiFi
nmcli> print connection.metered 
connection.metered: unknown 
nmcli> set connection.metered yes 
nmcli> print connection.metered 
connection.metered: yes 
nmcli> save 
Connection 'MyWiFi' (UUID-number-here) successfully updated. 
nmcli>quit

Done.
I cannot guarantee that it works as expected yet. I have setup one of my laptops as per the above, so in theory it should check for updates when using the wired connection or the corporate WiFi, but NOT when using my mobile router.
I’ll report back if I find something odd with that setting.

Installed from openSUSE-Leap-15.2-DVD-x86_64.iso some time ago. Nothing was downloaded until I checked “Activate online repositories now”. On activation zypper fills the cache with repo metadata:

erlangen:~ # du -hd1 /var/cache/zypp
34M     /var/cache/zypp/solv
0       /var/cache/zypp/packages
33M     /var/cache/zypp/raw
4.0K    /var/cache/zypp/pubkeys
67M     /var/cache/zypp
erlangen:~ # 

Download of packages only occurs when asked for by running zypper commands install, update or dist-upgrade.

Interesting.

I don’t use Gnome often enough for that to matter, but it is interesting anyway.

Apparently it works as expected:

LT_B:~ # zypper up -D 
**Retrieving repository** 'Packman Repository' metadata .........................................................................................................................................................[done] 
Building repository 'Packman Repository' cache ..............................................................................................................................................................[done] 
**Retrieving repository** 'openSUSE-Leap-15.1-Update' metadata ..................................................................................................................................................[done] 
Building repository 'openSUSE-Leap-15.1-Update' cache .......................................................................................................................................................[done] 
Loading repository data... 
Reading installed packages... 
 
The following 5 packages are going to be upgraded: 
  fwupd fwupd-lang java-11-openjdk java-11-openjdk-headless libfwupd2 
 
5 packages to upgrade. 
Overall download size: 36.6 MiB. **Already cached: 0 B.** After the operation, additional 44.0 KiB will be used. 
Continue? [y/n/v/...? shows all options] (y):

While on the “metered” connection PackageKit didn’t refresh repositories nor downloaded packages in the background.