openSUSE-SU-2022:0769-1: important: Security update for libcaca

openSUSE Security Update: Security update for libcaca ______________________________________________________________________________ Announcement ID: openSUSE-SU-2022:0769-1 Rating: important References: #1184751 #1184752 Cross-References: CVE-2021-30498 CVE-2021-30499 CVSS scores: CVE-2021-30498 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVE-2021-30498 (SUSE): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVE-2021-30499 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVE-2021-30499 (SUSE): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H Affected Products: openSUSE Leap 15.3 openSUSE Leap 15.4 ______________________________________________________________________________ An update that fixes two vulnerabilities is now available. Description: This update for libcaca fixes the following issues: - CVE-2021-30498, CVE-2021-30499: If an image has a size of 0x0, when exporting, no data is written and space is allocated for the header only, not taking into account that sprintf appends a NUL byte (bsc#1184751, bsc#1184752). Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-769=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-769=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): caca-utils-0.99.beta19.git20171003-11.3.1 caca-utils-debuginfo-0.99.beta19.git20171003-11.3.1 libcaca-debugsource-0.99.beta19.git20171003-11.3.1 libcaca-devel-0.99.beta19.git20171003-11.3.1 libcaca-ruby-0.99.beta19.git20171003-11.3.1 libcaca-ruby-debuginfo-0.99.beta19.git20171003-11.3.1 libcaca0-0.99.beta19.git20171003-11.3.1 libcaca0-debuginfo-0.99.beta19.git20171003-11.3.1 libcaca0-plugins-0.99.beta19.git20171003-11.3.1 libcaca0-plugins-debuginfo-0.99.beta19.git20171003-11.3.1 - openSUSE Leap 15.4 (x86_64): libcaca0-32bit-0.99.beta19.git20171003-11.3.1 libcaca0-32bit-debuginfo-0.99.beta19.git20171003-11.3.1 libcaca0-plugins-32bit-0.99.beta19.git20171003-11.3.1 libcaca0-plugins-32bit-debuginfo-0.99.beta19.git20171003-11.3.1 - openSUSE Leap 15.4 (noarch): python3-caca-0.99.beta19.git20171003-11.3.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): caca-utils-0.99.beta19.git20171003-11.3.1 caca-utils-debuginfo-0.99.beta19.git20171003-11.3.1 libcaca-debugsource-0.99.beta19.git20171003-11.3.1 libcaca-devel-0.99.beta19.git20171003-11.3.1 libcaca-ruby-0.99.beta19.git20171003-11.3.1 libcaca-ruby-debuginfo-0.99.beta19.git20171003-11.3.1 libcaca0-0.99.beta19.git20171003-11.3.1 libcaca0-debuginfo-0.99.beta19.git20171003-11.3.1 libcaca0-plugins-0.99.beta19.git20171003-11.3.1 libcaca0-plugins-debuginfo-0.99.beta19.git20171003-11.3.1 - openSUSE Leap 15.3 (x86_64): libcaca0-32bit-0.99.beta19.git20171003-11.3.1 libcaca0-32bit-debuginfo-0.99.beta19.git20171003-11.3.1 libcaca0-plugins-32bit-0.99.beta19.git20171003-11.3.1 libcaca0-plugins-32bit-debuginfo-0.99.beta19.git20171003-11.3.1 - openSUSE Leap 15.3 (noarch): python3-caca-0.99.beta19.git20171003-11.3.1 References: https://www.suse.com/security/cve/CVE-2021-30498.html https://www.suse.com/security/cve/CVE-2021-30499.html https://bugzilla.suse.com/1184751 https://bugzilla.suse.com/1184752

More…