openSUSE-SU-2022:10102-1: important: Security update for freeciv

openSUSE Security Update: Security update for freeciv ______________________________________________________________________________ Announcement ID: openSUSE-SU-2022:10102-1 Rating: important References: #1202548 Cross-References: CVE-2022-6083 Affected Products: openSUSE Backports SLE-15-SP4 ______________________________________________________________________________ An update that fixes one vulnerability is now available. Description: This update for freeciv fixes the following issues: - update to 3.0.3 (boo#1202548, CVE-2022-6083): * 3.0.3 is a bugfix release * see https://freeciv.fandom.com/wiki/NEWS-3.0.3 - update to 3.0.2: * 3.0.2 is a generic bugfix release * see https://freeciv.fandom.com/wiki/NEWS-3.0.2 - update to 3.0.1: * 3.0.1 is a generic bugfix release * see https://freeciv.fandom.com/wiki/NEWS-3.0.1 - update to 3.0.0: * This release is a major upgrade which with some changes that can support backward compatible rulesets * see https://freeciv.fandom.com/wiki/NEWS-3.0.0#WHAT.27S_CHANGED_SINCE_2.6 - update to 2.6.6: * https://freeciv.fandom.com/wiki/NEWS-2.6.5 * 2.6.6 is a bugfix release. Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP4: zypper in -t patch openSUSE-2022-10102=1 Package List: - openSUSE Backports SLE-15-SP4 (aarch64 i586 ppc64le s390x x86_64): freeciv-3.0.3-bp154.2.3.1 freeciv-gtk3-3.0.3-bp154.2.3.1 freeciv-lang-3.0.3-bp154.2.3.1 freeciv-qt-3.0.3-bp154.2.3.1 References: https://www.suse.com/security/cve/CVE-2022-6083.html https://bugzilla.suse.com/1202548

More…