openSUSE-SU-2022:0065-1: important: Security update for envoy-proxy

openSUSE Security Update: Security update for envoy-proxy ______________________________________________________________________________ Announcement ID: openSUSE-SU-2022:0065-1 Rating: important References: #1167073 #1173559 #1180121 Cross-References: CVE-2020-12603 CVE-2020-12604 CVE-2020-12605 CVE-2020-35471 CVE-2020-8663 CVSS scores: CVE-2020-12603 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2020-12604 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2020-12605 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2020-35471 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2020-35471 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H Affected Products: openSUSE Backports SLE-15-SP3 ______________________________________________________________________________ An update that fixes 5 vulnerabilities is now available. Description: This update for envoy-proxy fixes the following issues: Update to 1.14.6: - CVE-2020-35471: Fixed a denial of service via dropped and truncated UDP datagrams (boo#1180121). Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP3: zypper in -t patch openSUSE-2022-65=1 Package List: - openSUSE Backports SLE-15-SP3 (aarch64 ppc64le x86_64): envoy-proxy-1.14.6-bp153.3.4.1 envoy-proxy-source-1.14.6-bp153.3.4.1 References: https://www.suse.com/security/cve/CVE-2020-12603.html https://www.suse.com/security/cve/CVE-2020-12604.html https://www.suse.com/security/cve/CVE-2020-12605.html https://www.suse.com/security/cve/CVE-2020-35471.html https://www.suse.com/security/cve/CVE-2020-8663.html https://bugzilla.suse.com/1167073 https://bugzilla.suse.com/1173559 https://bugzilla.suse.com/1180121

More…