openSUSE-SU-2022:0091-1: important: Security update for apache2

openSUSE Security Update: Security update for apache2______________________________________________________________________________Announcement ID: openSUSE-SU-2022:0091-1Rating: importantReferences: #1193942 #1193943 #1197552 SLE-22733 SLE-22849 Cross-References: CVE-2021-44224 CVE-2021-44790 CVE-2022-1096 CVSS scores: CVE-2021-44224 (NVD) : 8.2 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H CVE-2021-44224 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2021-44790 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVE-2021-44790 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HAffected Products: openSUSE Backports SLE-15-SP3 openSUSE Leap 15.3______________________________________________________________________________ An update that fixes three vulnerabilities, contains two features is now available.Description: This update for apache2 fixes the following issues: Apache2 was updated to the current stable version 2.4.51 (jsc#SLE-22733 jsc#SLE-22849) It fixes all CVEs and selected bugs represented by patches found between 2.4.23 and 2.4.51. See https://downloads.apache.org/httpd/CHANGES_2.4 for a complete change log. Also fixed: - CVE-2021-44224: Fixed NULL dereference or SSRF in forward proxy configurations (bsc#1193943) - CVE-2021-44790: Fixed buffer overflow when parsing multipart content in mod_lua (bsc#1193942)Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-91=1 - openSUSE Backports SLE-15-SP3: zypper in -t patch openSUSE-2022-91=1Package List: - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): apache2-2.4.51-3.37.1 apache2-debuginfo-2.4.51-3.37.1 apache2-debugsource-2.4.51-3.37.1 apache2-devel-2.4.51-3.37.1 apache2-event-2.4.51-3.37.1 apache2-event-debuginfo-2.4.51-3.37.1 apache2-example-pages-2.4.51-3.37.1 apache2-prefork-2.4.51-3.37.1 apache2-prefork-debuginfo-2.4.51-3.37.1 apache2-utils-2.4.51-3.37.1 apache2-utils-debuginfo-2.4.51-3.37.1 apache2-worker-2.4.51-3.37.1 apache2-worker-debuginfo-2.4.51-3.37.1 - openSUSE Leap 15.3 (noarch): apache2-doc-2.4.51-3.37.1 - openSUSE Backports SLE-15-SP3 (aarch64 x86_64): chromedriver-99.0.4844.84-bp153.2.75.1 chromium-99.0.4844.84-bp153.2.75.1References: https://www.suse.com/security/cve/CVE-2021-44224.html https://www.suse.com/security/cve/CVE-2021-44790.html https://www.suse.com/security/cve/CVE-2022-1096.html https://bugzilla.suse.com/1193942 https://bugzilla.suse.com/1193943 https://bugzilla.suse.com/1197552

More…