openSUSE-SU-2021:1183-1: moderate: Security update for fetchmail

openSUSE Security Update: Security update for fetchmail______________________________________________________________________________Announcement ID: openSUSE-SU-2021:1183-1Rating: moderateReferences: #1188034 #1188875 Cross-References: CVE-2021-36386CVSS scores: CVE-2021-36386 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2021-36386 (SUSE): 5.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:LAffected Products: openSUSE Leap 15.2______________________________________________________________________________ An update that solves one vulnerability and has one errata is now available.Description: This update for fetchmail fixes the following issues: - CVE-2021-36386: Fixed a missing variable initialization that can cause read from bad memory locations. (bsc#1188875) - Change PASSWORDLEN from 64 to 256 (bsc#1188034) This update was imported from the SUSE:SLE-15:Update update project.Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-1183=1Package List: - openSUSE Leap 15.2 (x86_64): fetchmail-6.3.26-lp152.6.6.1 fetchmail-debuginfo-6.3.26-lp152.6.6.1 fetchmail-debugsource-6.3.26-lp152.6.6.1 fetchmailconf-6.3.26-lp152.6.6.1References: https://www.suse.com/security/cve/CVE-2021-36386.html https://bugzilla.suse.com/1188034 https://bugzilla.suse.com/1188875

More…