openSUSE-SU-2021:1876-1: important: Security update for snakeyaml

openSUSE Security Update: Security update for snakeyaml______________________________________________________________________________Announcement ID: openSUSE-SU-2021:1876-1Rating: importantReferences: #1159488 #1186088 Cross-References: CVE-2017-18640CVSS scores: CVE-2017-18640 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2017-18640 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HAffected Products: openSUSE Leap 15.3______________________________________________________________________________ An update that solves one vulnerability and has one errata is now available.Description: This update for snakeyaml fixes the following issues: - Upgrade to 1.28 - CVE-2017-18640: The Alias feature allows entity expansion during a load operation (bsc#1159488, bsc#1186088)Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-1876=1Package List: - openSUSE Leap 15.3 (noarch): snakeyaml-1.28-3.5.1 snakeyaml-javadoc-1.28-3.5.1References: https://www.suse.com/security/cve/CVE-2017-18640.html https://bugzilla.suse.com/1159488 https://bugzilla.suse.com/1186088

More…