openSUSE-SU-2021:3758-1: important: Security update for postgresql12

openSUSE Security Update: Security update for postgresql12______________________________________________________________________________Announcement ID: openSUSE-SU-2021:3758-1Rating: importantReferences: #1192516 Cross-References: CVE-2021-23214 CVE-2021-23222CVSS scores: CVE-2021-23214 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVE-2021-23222 (SUSE): 3.7 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:NAffected Products: openSUSE Leap 15.3______________________________________________________________________________ An update that fixes two vulnerabilities is now available.Description: This update for postgresql12 fixes the following issues: - CVE-2021-23214: Make the server reject extraneous data after an SSL or GSS encryption handshake (bsc#1192516). - CVE-2021-23222: Make libpq reject extraneous data after an SSL or GSS encryption handshake (bsc#1192516).Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-3758=1Package List: - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): postgresql12-12.9-8.26.1 postgresql12-contrib-12.9-8.26.1 postgresql12-contrib-debuginfo-12.9-8.26.1 postgresql12-debuginfo-12.9-8.26.1 postgresql12-debugsource-12.9-8.26.1 postgresql12-devel-12.9-8.26.1 postgresql12-devel-debuginfo-12.9-8.26.1 postgresql12-llvmjit-12.9-8.26.1 postgresql12-llvmjit-debuginfo-12.9-8.26.1 postgresql12-plperl-12.9-8.26.1 postgresql12-plperl-debuginfo-12.9-8.26.1 postgresql12-plpython-12.9-8.26.1 postgresql12-plpython-debuginfo-12.9-8.26.1 postgresql12-pltcl-12.9-8.26.1 postgresql12-pltcl-debuginfo-12.9-8.26.1 postgresql12-server-12.9-8.26.1 postgresql12-server-debuginfo-12.9-8.26.1 postgresql12-server-devel-12.9-8.26.1 postgresql12-server-devel-debuginfo-12.9-8.26.1 postgresql12-test-12.9-8.26.1 - openSUSE Leap 15.3 (noarch): postgresql12-docs-12.9-8.26.1References: https://www.suse.com/security/cve/CVE-2021-23214.html https://www.suse.com/security/cve/CVE-2021-23222.html https://bugzilla.suse.com/1192516

More…