openSUSE-SU-2021:1611-1: important: Security update for p11-kit

openSUSE Security Update: Security update for p11-kit______________________________________________________________________________Announcement ID: openSUSE-SU-2021:1611-1Rating: importantReferences: #1180064 #1187993 Cross-References: CVE-2020-29361CVSS scores: CVE-2020-29361 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2020-29361 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HAffected Products: openSUSE Leap 15.2______________________________________________________________________________ An update that solves one vulnerability and has one errata is now available.Description: This update for p11-kit fixes the following issues: - CVE-2020-29361: Fixed multiple integer overflows in rpc code (bsc#1180064) - Add support for CKA_NSS_{SERVER,EMAIL}_DISTRUST_AFTER (bsc#1187993). This update was imported from the SUSE:SLE-15:Update update project.Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-1611=1Package List: - openSUSE Leap 15.2 (i586 x86_64): libp11-kit0-0.23.2-lp152.7.3.1 libp11-kit0-debuginfo-0.23.2-lp152.7.3.1 p11-kit-0.23.2-lp152.7.3.1 p11-kit-debuginfo-0.23.2-lp152.7.3.1 p11-kit-debugsource-0.23.2-lp152.7.3.1 p11-kit-devel-0.23.2-lp152.7.3.1 p11-kit-nss-trust-0.23.2-lp152.7.3.1 p11-kit-tools-0.23.2-lp152.7.3.1 p11-kit-tools-debuginfo-0.23.2-lp152.7.3.1 - openSUSE Leap 15.2 (x86_64): libp11-kit0-32bit-0.23.2-lp152.7.3.1 libp11-kit0-32bit-debuginfo-0.23.2-lp152.7.3.1 p11-kit-32bit-0.23.2-lp152.7.3.1 p11-kit-32bit-debuginfo-0.23.2-lp152.7.3.1 p11-kit-nss-trust-32bit-0.23.2-lp152.7.3.1References: https://www.suse.com/security/cve/CVE-2020-29361.html https://bugzilla.suse.com/1180064 https://bugzilla.suse.com/1187993

More…