openSUSE-SU-2021:1343-1: important: Security update for nodejs8

openSUSE Security Update: Security update for nodejs8______________________________________________________________________________Announcement ID: openSUSE-SU-2021:1343-1Rating: importantReferences: #1188917 Cross-References: CVE-2021-22930CVSS scores: CVE-2021-22930 (SUSE): 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NAffected Products: openSUSE Leap 15.2______________________________________________________________________________ An update that fixes one vulnerability is now available.Description: nodejs8 was updated to fix the following security issues: - CVE-2021-22930: http2: fixes use after free on close in stream canceling (bsc#1188917) This update was imported from the SUSE:SLE-15-SP2:Update update project.Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-1343=1Package List: - openSUSE Leap 15.2 (i586 x86_64): nodejs8-8.17.0-lp152.3.17.1 nodejs8-debuginfo-8.17.0-lp152.3.17.1 nodejs8-debugsource-8.17.0-lp152.3.17.1 nodejs8-devel-8.17.0-lp152.3.17.1 npm8-8.17.0-lp152.3.17.1 - openSUSE Leap 15.2 (noarch): nodejs8-docs-8.17.0-lp152.3.17.1References: https://www.suse.com/security/cve/CVE-2021-22930.html https://bugzilla.suse.com/1188917

More…