openSUSE-SU-2021:0788-1: important: Security update for mpv

openSUSE Security Update: Security update for mpv ______________________________________________________________________________ Announcement ID: openSUSE-SU-2021:0788-1 Rating: important References: #1186230 Cross-References: CVE-2021-30145 Affected Products: openSUSE Leap 15.2 ______________________________________________________________________________ An update that fixes one vulnerability is now available. Description: This update for mpv fixes the following issues: - CVE-2021-30145: Fixed format string vulnerability allows user-assisted remote attackers to achieve code execution via a crafted m3u playlist file (boo#1186230) Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-788=1 Package List: - openSUSE Leap 15.2 (x86_64): libmpv1-0.32.0+git.20200301T004003.e7bab0025f-lp152.2.6.1 libmpv1-debuginfo-0.32.0+git.20200301T004003.e7bab0025f-lp152.2.6.1 mpv-0.32.0+git.20200301T004003.e7bab0025f-lp152.2.6.1 mpv-debuginfo-0.32.0+git.20200301T004003.e7bab0025f-lp152.2.6.1 mpv-debugsource-0.32.0+git.20200301T004003.e7bab0025f-lp152.2.6.1 mpv-devel-0.32.0+git.20200301T004003.e7bab0025f-lp152.2.6.1 - openSUSE Leap 15.2 (noarch): mpv-bash-completion-0.32.0+git.20200301T004003.e7bab0025f-lp152.2.6.1 mpv-zsh-completion-0.32.0+git.20200301T004003.e7bab0025f-lp152.2.6.1 References: https://www.suse.com/security/cve/CVE-2021-30145.html https://bugzilla.suse.com/1186230

More…