openSUSE-SU-2021:0295-1: important: Security update for librepo

openSUSE Security Update: Security update for librepo______________________________________________________________________________Announcement ID: openSUSE-SU-2021:0295-1Rating: importantReferences: #1175475 Cross-References: CVE-2020-14352CVSS scores: CVE-2020-14352 (NVD) : 8 CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H CVE-2020-14352 (SUSE): 8 CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HAffected Products: openSUSE Backports SLE-15-SP2______________________________________________________________________________ An update that fixes one vulnerability is now available.Description: This update for librepo fixes the following issues: - Upgrade to 1.12.1 + Validate path read from repomd.xml (bsc#1175475, CVE-2020-14352) - Changes from 1.12.0 + Prefer mirrorlist/metalink over baseurl (rh#1775184) + Decode package URL when using for local filename (rh#1817130) + Fix memory leak in lr_download_metadata() and lr_yum_download_remote() + Download sources work when at least one of specified is working (rh#1775184) This update was imported from the SUSE:SLE-15-SP2:Update update project. This update was imported from the openSUSE:Leap:15.2:Update update project.Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP2: zypper in -t patch openSUSE-2021-295=1Package List: - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64): librepo-devel-1.12.1-bp152.2.6.1 librepo0-1.12.1-bp152.2.6.1 python3-librepo-1.12.1-bp152.2.6.1References: https://www.suse.com/security/cve/CVE-2020-14352.html https://bugzilla.suse.com/1175475

More…