openSUSE-SU-2021:0906-1: important: Security update for libnettle

openSUSE Security Update: Security update for libnettle ______________________________________________________________________________ Announcement ID: openSUSE-SU-2021:0906-1 Rating: important References: #1187060 Cross-References: CVE-2021-3580 CVSS scores: CVE-2021-3580 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H Affected Products: openSUSE Leap 15.2 ______________________________________________________________________________ An update that fixes one vulnerability is now available. Description: This update for libnettle fixes the following issues: - CVE-2021-3580: Fixed a remote denial of service in the RSA decryption via manipulated ciphertext (bsc#1187060). This update was imported from the SUSE:SLE-15:Update update project. Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-906=1 Package List: - openSUSE Leap 15.2 (i586 x86_64): libhogweed4-3.4.1-lp152.4.6.1 libhogweed4-debuginfo-3.4.1-lp152.4.6.1 libnettle-debugsource-3.4.1-lp152.4.6.1 libnettle-devel-3.4.1-lp152.4.6.1 libnettle6-3.4.1-lp152.4.6.1 libnettle6-debuginfo-3.4.1-lp152.4.6.1 nettle-3.4.1-lp152.4.6.1 nettle-debuginfo-3.4.1-lp152.4.6.1 - openSUSE Leap 15.2 (x86_64): libhogweed4-32bit-3.4.1-lp152.4.6.1 libhogweed4-32bit-debuginfo-3.4.1-lp152.4.6.1 libnettle-devel-32bit-3.4.1-lp152.4.6.1 libnettle6-32bit-3.4.1-lp152.4.6.1 libnettle6-32bit-debuginfo-3.4.1-lp152.4.6.1 References: https://www.suse.com/security/cve/CVE-2021-3580.html https://bugzilla.suse.com/1187060

More…