openSUSE setup crashes while repairing installation

I am facing some issues with my openSUSE 11.2 installtion.
:frowning: Yesterday i installed win 7 so the grub is now wiped out :frowning: . I have also taken mbr backup in USB. I tried following things to make things work.

1) Repair using openSUSE DVD
   booted using DVD then automatic repair but it couldn't     find any root partition 
  After showing error that no root partition found it crashes to a blue screen with advanced configurations from there i was able to use shell but cant see and mount any linux partitions. 

i tried mounting the root partition it gave the error :"please load module ext4dev before mounting" as i am not that much expert please tell me how can i install grub without losing my present installations. 

2) Tried booting with Ubuntu & kubuntu 8.04 live cd .. both gave a error and refused to boot. then tried openSolaris which failed to detect the USB drive so couldnt restore the GRUB to /dev/hda.

Please guys help me to install the GRUB so that i can get my suse installation back ..

advance thanks for the help ...:)

3)After this post tired Auto grub disk tool to restore grub looks as it is restored but cant boot it is refusing to boot see the error i am getting. yesterday it was absolutely fine. I have not done any config changes just installed Win 7 nothing else …]

Did openSUSE work before you installed Windows ?
What happen if you boot openSUSE live CD ? (Don’t try to repair anything, just boot!)
Why would Ubuntu livecd not work ?

  • bad CD (?)
  • wrong version (32/64 bit) (?)
  • serious hardware problem {?}

Otherwise it should boot, whatever you have on your HD, even without HD at all. Also why such an old Ubuntu ? (if I may ask).

There is a way !!! You tried the repair function from the boot menu I assume. This is what you do:

Boot from the install DVD. Select Installation and start the install procedure. Don’t worry, this is still doing nothing to your current installs.
You will get to a screen where it says: New Install. There you will also find IIRC a hidden option “Boot installed system”. This will bypass the corrupted bootloader and attempt to start a detected openSUSE system. Once back in your installed openSUSE, you can reinstall GRUB from Yast.

Please get back here with results.

Your’re trying to boot the wrong partition. Type 07 is ntfs (Windows). It should be 83 for Linux.
So root (hd0,7) is wrong.

openSUSE was working fine before installing win 7
Actually i tried those old ubuntu versions because i was having those only… today i will try 9.04 too … i also tried with Slax Live CD too but it too crahed before login … I dont have a openSUSE Live CD so cant boot with that

Thanks bro going to try this will update with the results

Thanks bro going to try that will update here results …

Thanks bro going to try that will update here results …

After trying for 3 hours today end result was 0.

1)I tried to install the bootloader but it failed again.
the issue seems that after installing the device names have changed … previously the root partition was on /dev/sda7 and now it is showing on /dev/sda6.
I mounted sd6 and was able to see the root partition. so the device mapping may have changed too … as per the SUSE’s installer suggestion it is /dev/disk-id/…something…/part6 … previously it was /part8. I checked Old settings from fstab file.

Is this possible that windows changed the names … or there is some superblocks problem. What shall i do as every step is failing :frowning: i will try all sorts of methods before monday if no success will reinstall SUSE

I don’t think that even Windows would change partitions like that. The partition table is in the first sector of the drive, part of the MBR. Also I believe each extended partition has a table as its first sector. The partitions are actually not named just enumerated.

Hi Knurpht,

Can you tell me where I can find this hidden option “Boot installed system”? What I found is three options: New Installation, Update and Repair Installed System.

In short my problem is that after update of the new kernel I couldn’t shut down my PC and I tried to repair it and then couldn’t access the computer. Your method seems promising but before I could make another big mistake I’d like to make it clear.

Thanks in advance!

Select install I think the option is in the next screen. The installer will not change anything until you complete all the configurations and say ok to the proposed installation.

We need to see the partition you currently have from a Linux stand point. So you need to boot a Linux distro or rescue disk like gparted or supergrub. and give the output of fdisk -l. THe Windows tools are near useless.