OpenSuse Samba Share Accessible from Win7- 64B-Ult, but not Win2008 Server.

I had two servers that were both running OpenSuse 12.2. The shares from both servers were accessible from our Windows 2008 Server. One of the OpenSuse servers crashed, so I took the opportunity to rebuild it using OpenSuse 13.2. I used the same smb.conf file as I did when the server had 12.2 on it. However, now I can not access the samba shares on the 13.2 server with windows2008 server, but I can access it with windows 7 64 bit Ultimate. I did notice that the 12.2 server is running samba version 3.6.7, and the 13.2 server is running samba version 4.1.18. I really need to be able to access this share from the Windows 2008 Server. Is this maybe a setting that needs to be tweaked on the Suse 13.2 box, or would it be a setting on the windows 2008 server that needs to be tweaked to be able to interact with the newer samba version? Any help or ideas would be much appreciated.

Regards,
Tony

On 2015-07-02 00:16, TonyLudwick wrote:

> 64 bit Ultimate. I did notice that the 12.2 server is running samba
> version 3.6.7, and the 13.2 server is running samba version 4.1.18.

perhaps:

https://www.suse.com/releasenotes/i386/openSUSE/13.2/RELEASE-NOTES.en.html

https://www.suse.com/releasenotes/i386/openSUSE/13.1/RELEASE-NOTES.en.html#idp315834436


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

I don’t know that there is a certain quick fix, but it should be noted that SAMBA 3.x is based on NT4 Domains, and SAMBA 4.x is based on Active Directory.

A troubleshooting starting point I’d suggest is that Win7 and Server 2008 are based on the same generation technology bits so if one can connect and the other can’t, then I’d start there, and maybe with the Windows AD backwards compatibility setting.

Another issue could be namespaces… Whenever I re-build and replace something in a Windows network (even on an individual Windows machine), I’m careful to build the new machine with completely new namespaces… That means everything from the machine name to the share names and everything else that is referenced by name on the machine. This is because Windows has the memory of an elephant… every device ever connected to the machine, every other machine its ever touched or acceessed, services running locally and sometimes remotely, every app ever installed or run on the machine is assigned a unique ID and remembered forever unless you’re willing to manually dig into the Registry. So, to ensure that a new machine runs flawlessly it has to be absolutely unique in every way to avoid having to purge Registry entries, caches, AD objects and more sometimes throughout your network.

PS. If the above isn’t clear, all namespaces must map to their IDs. Machines identify objects by their IDs while humans identify objects by names. If mappings aren’t correct due to cached configurations and entries, that’s a major cause when machines won’t do what humans expect. By avoiding names already used before on old machines, you can avoid old, obsolete or conflicting mappings.

In other words, if you didn’t follow what I just described then it might be better to start over again or risk eternal ****ation peering into odd rabbit holes in your network.

TSU

On 7/3/2015 12:06 PM, tsu2 wrote:
> I don’t know that there is a certain quick fix, but it should be noted
> that SAMBA 3.x is based on NT4 Domains, and SAMBA 4.x is based on Active
> Directory.
TSU;

As long as you are using only smbd and nmbd Samba4 works exactly like Samba3. The AD capabilities use a new daemon
called “samba”. See: https://www.samba.org/samba/docs/man/manpages/samba.7.html and/or
https://www.samba.org/samba/docs/man/manpages/samba.8.html


P.V.
“We’re all in this together, I’m pulling for you” Red Green