Opensuse root password forgotten

I have forgotten my root password.
i tried already the introduction with
mount root partition and then chroot etc. but i got the mistake:
/dev/urandom was not founded or something like this
changing root passwort failed

also i tried:
etc/shadow and then delete all after root:
but now it doesn’t recognize a password

what is to do?

In my deem you made wrong, because you had only to modify /etc/password from




this way you can login as root with no password. After that you can give a new password.

Yes that i already noticed too
i had deleted all
and what is with shadow?

Your real password is written encrypted in /etc/shadow.

And what is to do with shadow?
Or have i only to change the passwd and then it works?

Have you tried to modify /etc/password and reboot? after that you should change your root password and this new password will be written in /etc/shadow.


I just tried this under Suse 11.1 for educational purpose and it didn’t work. I deleted the x in /etc/password and I got no access. Also deleting the password in /etc/shadow didn’t help. Seems to be a security feature of Suse. So another trick:

Just copy the encrypted password of another user and replace the root password in /etc/shadow. To do so you need a live CD like Knoppix. After launching the system you can log in as root with the known password of the user and set a new one for root.




OK I will try

handy bookmark… How to reset/recover the ROOT password in openSUSE | SUSE & openSUSE

Thanks this introduction is good