openSUSE RC1: Konqueror sysinfo:/ not working

Anybody confirm this? After yesterday’s Factory updates to 11.2 RC1 ‘konqueror sysinfo:/’ stopped working. I get an ‘unexpected program termination’.
I know this happened before, don’t remember how it was solved.

Yes, since yesterdays updates sysinfo she no work.

sysinfo - works OK for me. M8 upgraded to RC1

it even now shows the nvidia driver info

I also updated but everything including Konqueror sysinfo seems to be working normally.

Sysinfo:/ not working for me, either on my Linux box or my MacBook with RC1 installed as a guest in virtualbox.

Same here. sysinfo crashes repeatedly … unexpected termination

In a fresh install of RC-1 sysinfo worked until I added these repos and upgraded:

:~> zypper -v lr
Verbosity: 1
#  | Alias                               | Name                            | Enabled | Refresh
1  | Anubisg1/openSUSE_Factory           | Anubisg1/openSUSE_Factory       | Yes     | Yes
2  | KDE:/43/openSUSE_Factory            | KDE:/43/openSUSE_Factory        | Yes     | Yes
3  | KDE:/Backports/openSUSE_11.2        | KDE:/Backports/openSUSE_11.2    | No      | No
4  | KDE:/Community/openSUSE_Factory     | KDE:/Community/openSUSE_Factory | No      | No
5  | Mozilla/openSUSE_Factory            | Mozilla/openSUSE_Factory        | Yes     | Yes
6  | Packman/suse/factory                | Packman/suse/factory            | Yes     | Yes
7  | VLC/SuSE/11.2                       | VLC/SuSE/11.2                   | Yes     | Yes
8  | | Updates for openSUSE 11.2-0     | Yes     | Yes
9  | openSUSE 11.2-0                     | openSUSE 11.2-0                 | No      | No
10 | repo-debug                          | openSUSE-11.2-Debug             | No      | No
11 | repo-non-oss                        | openSUSE-11.2-Non-Oss           | Yes     | Yes
12 | repo-oss                            | openSUSE-11.2-Oss               | Yes     | Yes
13 | repo-source                         | openSUSE-11.2-Source            | No      | No

Now it doesn’t work again. Best guess here is something in KDE 43 Factory repo???

I’m running on a purer line than that
And all is fine.

| Packman | Packman | Yes | Yes | 98 | rpm-md | Index of /pub/linux/misc/packman/suse/factory |
2 | | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
3 | openSUSE 11.2-0 | openSUSE 11.2-0 | No | No | 99 | yast2 | cd:/// |
4 | repo-debug | openSUSE-11.2-Debug | No | No | 99 | NONE | |
5 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | |
6 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | |
7 | repo-source | openSUSE-11.2-Source | No | No | 99 | NONE | |

Same here, upgrade from M8 to RC1 and sysinfo doesn’t work. I’m not sure what would be the problem, though. If anybody has some suggestions, I’d gladly try them.

Knurpht wrote:
> Anybody confirm this? After yesterday’s Factory updates to 11.2 RC1
> ‘konqueror sysinfo:/’ stopped working. I get an ‘unexpected program
> termination’.
> I know this happened before, don’t remember how it was solved.

No idea if this is connected but I had some different problem with RC1’s
kernel. My UMTS modem went tits up.

I was advised in the factory mailing list and it was said to be a bug in
the kernel (upstream).

When I rolled back to the previous, M8 kernel It got fixed.
I didn’t try sysinfo then, but at least it seems to be working here now.

The kernel i have now:

Here’s another:

The machine here is EeePC 900. Everything else is fine, too :slight_smile:


“Sunrise 8:07am (EEST), sunset 6:03pm (EEST) at Espoo, Finland (9:56
hours daylight)”
Linux #1 SMP 2009-08-14 01:48:11 +0200 x86_64
11:56am up 25 days 18:36, 10 users, load average: 0.10, 0.28, 0.26

I’m using those exact same repos and so far I have not run into any bugs.

I’ll disable the old KDE4 repos for Playground and Community, do an unconditional update of all KDE4 packages and see what that does. I’ve had this before and got it solved, AFAIR by doing that. I’ll keep you posted

Beware trying this could break all or some of your system.

This is what I know and ALL I know because I DON’T know enough about how the different KDE packages work together.

If I disable KDE 43 repo and downgrade to 4.3.1 sysinfo works. Upon enabling KDE 43 and upgrading to 4.3.2 then again sysinfo doesn’t work. So I then tried [with 43 repo enabled and in 4.3.2 release 2] downgrading kio_sysinfo-11.2-29.1 to kio_sysinfo-11.2-28.1 and sysinfo works again.

So it appears that a specific package or packages of kio_sysinfo has a bug. Now I get to read up on where to file a bug report.

openSUSE RC1: Konqueror sysinfo: works on my sandbox PC. Its an athlon-1100 with 1GB RAM and a nVidia GeForce FX5200.

I did a clean install from the 11.2 RC1 32-bit installation DVD selecting a KDE4 desktop.

Ditto here.
I don’t intend to infest my system, I might try dup thru to the release.

I did a clean install from DVD 64-bit and sysinfo:/ works in Konqueror. Is the problem inherint with 32-bit updates only?

Yip, downgrading kio-sysinfo to the 11.2 repo version worked for me too.


Works here too. Updating unconditionally did not. I’ll do a clean install of RC1 on the laptop tonight.

For me, in 64 bit, this issue occurred [twice] when updating from M8 to RC1 with dup. In fresh install of RC1 sysinfo worked out of the box. THEN after adding KDE43 repo [and running dup] as noted above problem reoccurred. Then I downgraded kio_sysifo as described above and sysinfo again works.

Previously, sysinfo:/ wasn’t working for me. I updated kio_sysinfo today from the KDE43 repo and it’s working fine, although some of the info displayed is incorrect. It says I’m not online when I am, and it shows me using the nv driver when I’m using the proprietary nvidia module.