OpenSUSE Pushes my Idle GPU Temps Too High - Driver Issue

I have been running 13.1 for about a year and have noticed for some time, as I switch back and forth between Win7 and OpenSUSE, that the machine makes more fan noise when in OpenSUSE. I finally looked into what might be causing this and saw that GKrellM and Phoronix are both reporting my ATI Radeon HD5700 GPU temps at 63C. This is just running a normal desktop at idle - no 3D applications or anything like that. During normal operations on the Win7 desktop, my GPU temps rarely top 40C, so OpenSUSE is pushing these temps far beyond what they should be (hence the increased fan noise).

I am not using any proprietary drivers - everything seemed to work fine (before I noticed the elevated temps) as far as graphics goes, so I never tried to change whatever drivers the system used as default during my 13.1 installation.

Can anyone recommend how I can get these GPU temps back into the realm of reason?

On Tue 12 May 2015 02:46:01 AM CDT, mxcrowe wrote:

I have been running 13.1 for about a year and have noticed for some
time, as I switch back and forth between Win7 and OpenSUSE, that the
machine makes more fan noise when in OpenSUSE. I finally looked into
what might be causing this and saw that GKrellM and Phoronix are both
reporting my ATI Radeon HD5700 GPU temps at 63C. This is just running a
normal desktop at idle - no 3D applications or anything like that.
During normal operations on the Win7 desktop, my GPU temps rarely top
40C, so OpenSUSE is pushing these temps far beyond what they should be
(hence the increased fan noise).

I am not using any proprietary drivers - everything seemed to work fine
(before I noticed the elevated temps) as far as graphics goes, so I
never tried to change whatever drivers the system used as default during
my 13.1 installation.

Can anyone recommend how I can get these GPU temps back into the realm
of reason?

Hi
Normally with using the radeon module, setting the power to low should
bring things back to normal.
https://forums.opensuse.org/entry.php/142-Package-of-the-day-systemd-radeon-power_profile


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Hi Malcolm. Thanks for the reply. Should I not then use the Catalyst / fglrx driver found here?:
http://opensuse-community.org/

I assume your systemd-radeon-power_profile allows power control that is not provided for in the above driver?

I used the one-click installer to install the package for systemd-radeon-power_profile in 13.1
Do I then need to create the scripts shown on this page?: http://tirdc.livejournal.com/28471.html
Or is there some way to set the low power state using this tool directly? Sorry, it was not clear to me exactly what I needed to do.

Hi
Enable and start the service;


systemctl status radeon-power_profile.service
systemctl enable radeon-power_profile.service
systemctl start radeon-power_profile.service
systemctl status radeon-power_profile.service

The default profile is ‘low’ you can change via YaST /etc/sysctl editor and change as required.

Fantastic! That worked perfectly - dropped my GPU temp immediately to 39C. Man, I wish I had looked into this earlier…kicking myself a bit for not chasing down that higher fan noise before this. In any case, I’m replacing this gfx card soon, and I doubt running at 63C all the time did that much damage, as my airflow thru this machine is very good.

So, before I use an application that is graphics intensive, I need to manually make that power setting change in Yast each time?

Thanks again!

Hi
You can actually change from the command line as the systemd service just links to the script /usr/sbin/radeon-power_profile you should in theory not have to change it in YaST, else try the setting ‘auto’.

Does something similar exist for GeForce cards? The power_profile “file”
dose not exist on my system under /sys anywhere, so maybe not applicable.

Thanks.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…