openSUSE problems - a short list

I wanted to see if it is true that openSUSE is ready to replace Ubuntu, and it looks like it is not, at least from my point of view. Before I go into details, I will mention that running openSUSE alongside Vista and Ubuntu on the same PC. I don’t remember when was the last time I switched to Vista, as I spend 99% of the time on Ubuntu.

The good stuff about openSUSE:

  1. Centralized management (Yast)
  2. Better compatibility with MS Office documents. I have been able to verify this with several documents that have many tables and formulas.
  3. Very polished look.

The bad stuff (when comared to Ubuntu). The order in the list is random:

  1. If I plug a digital camera into my PC, a window pops up under Ubuntu offering me to import pictures/video clips. On openSUSE there is no such thing. I have to start F-spot under Gnome. I don’t even know what would be the KDE application as I’m not using it. One might argue that this is not important, but for a linux novice it might be a big deal.

  2. Restricted multimedia packages. I don’t know where to begin here. Under Gnome, installing the restricted meta package does not help, you have to go and add few more gstreamer plugins to be able to see all video formats with totem. Under KDE it works, but if you enable desktop effects the video goes black. Then you have to thinker with Gstreamer video input until you find that X (or whatever works for you) helps.

  3. More on multimedia: I tried ffmpeg from packman. It is compiled to support many formats, but the ffmpeg package will not install all libraries (e.g., libmp3lame, etc.). Under Ubuntu, if you enable Medibuntu repository, when you install ffmpeg it comes with all these libraries as dependencies, so that you don’t have to chase them separately. You install it and use it.

  4. Audio: The volume control icon didn’t work for me (just wouldn’t open) until I added myself to the pulse group. It took me a while to get microphone to work (I had none of these problems on Ubuntu, things just worked on the same PC). Then I tried to use Ekiga. Aside from the fact that I did not figure out yet what ports to set in firewall, after closing Ekiga, volume control doesn’t work again until I log out / log in again. Ekiga just works fine under Ubuntu, and since I’m sharing /home partition, it uses the same settings.

  5. KVM: On both Ubuntu and openSUSE it comes compiled to use /dev/dsp for audio instead of alsa (it puzzles me why this is the case). This works fine for some applications, but not for all of them. So, I downloaded the latest KVM, version 70, and it was not a problem to compile it with ALSA support under Ubuntu. Under openSUSE, after I chased all the libraries, it started to compile, and somewhere in the middle of it there was an error. I just gave up, because I spent a lot of time just to find all the libraries, only to find out that that was not enough.

  6. Some more on multimedia: It is easy to capture/edit videos from camcorders by using Kino. openSUSE decided not to provide binaries any more. I downloaded the latest Kino, and after reading through README file I saw that I will need a lot more libraries, so I’ll leave that for some weekend when I have more time at my hands.

In conclusion, I didn’t really spend much time with openSUSE, but all these things are putting me off simply because everything works on Ubuntu. Does the openSUSE community really believe that multimedia and easy of use are not important? Perhaps version 11.1 will be better.

On openSUSE KDE it does work. I have set it up to work on 4 different openSUSE PCs.

I had a Ubuntu friend complain to me it doesn’t work on Ubuntu. :rolleyes: Guess it doesn’t always “just work” on Ubuntu either.

No need to begin. I’ve had my Ubuntu friends grumble many times that they can’t get their Ubuntu multimedia tuned to the same level I have on openSUSE. Its an incredibly simple matter on openSUSE of setting up your repositories. Read the stickie I posted in multimedia. Look at the links.

I never use Totem. I don’t like it. IMHO smplayer, vlc, and even xine-ui and kaffeine are superior to Totem. Although frankly, reading the rest of your post, I’m not surprised you struggled … Please, no offense intended, … we all have to learn sometime.

You have a choice on openSUSE for either the vlc ffmpeg, or the Packman ffmpeg. Also, if you setup your repositories this is painless, and one can sort lame for ffmpeg. Again, my experience is the openSUSE ffmpeg has more up to date capabilities/features than that of the Ubuntu ffmpeg.

I’ve lost count of the number of times I have read of user-a note his sound worked for distribution-b, but not c. Hardware often works better in one distribution than other.

I can rattle off over a dozen cases of Ubuntu users not getting their sound to work. I spent some trying to help Ubuntu users with their sound in #alsa, until I stopped, as it was too frustrating. I was spending 95% of my time teaching the Ubuntu users Linux basics. But without doubt, the VAST majority of users with sound problems in #alsa are Ubuntu users.

Now thats NOT to say Ubuntu is bad for sound. IMHO its not. Ubuntu has the majority of Linux users and I would say the % of Ubuntu users with sound problems in IRC #alsa are about correct. Its simply no different than any other distro. I did observe in IRC #ubuntu that the help for sound was not very good, which was why IMHO many Ubuntu uses went to IRC #alsa for help.

Install Packman in your repos (or videolan). Its incredibly easy to do this.

It shows.

IMHO openSUSE is SIGNIFICANTLY superior to Ubuntu in multimedia.

IMHO your problem was you simply did not know what to do to set yours up, and rather than spend some time on this forum and IRC #suse trying to get help, you made an inaccurate assessment.

By the way, my friends who are struggling with Ubuntu multimedia have been using Ubuntu for over 3 years. They also really like Ubuntu, and I do my best to help them by email, and they send the occasion tidbit my way. But there are limits to the help one can provide via email.

I also have friend/colleagues who use Fedora, and they think it great. Some of them are VERY advanced in their Linux knowledge, and have their multimedia tuned quite nicely.

I see no point in bashing another distribution. There is far more to be gained by helping.

But I am on openSUSE for a reason, and multimedia is one BIG reason. With packman and videolan (plus some other less well known packagers), multimedia is simply better on openSUSE than most other Linux distributions. And that includes Ubuntu.

> 1. If I plug a digital camera into my PC, a window pops up under Ubuntu
> offering me to import pictures/video clips. On openSUSE there is no such
> thing.

works perfect for me, right out of the box…i plug in my camera and up
pops a box asking what i wanna do, with a list of stuff i can choose
from…should work for you too…tell me, if you plug a memory module
into a card reader, does it pop up a whatta wanna do box? (mine
does…maybe yours is broke, somehow)

> Perhaps version 11.1 will be better.

oh, you are using 11.0?? i have a couple of rules:

  • never load *.0 software

  • ESPECIALLY not if it is on a every six months release cycle

  • ALWAYS read the newsgroups/forums to see if a new release is full of
    problems, BEFORE installing…

consequently, i just recently moved from 10.2 to 10.3, and find i have
very satisfactory experience…and, expect in about a year to find 11.2
is pretty nice (AFTER reading the boards for six months or so)…

anything else you are just being a test pilot, without a chute!


DenverD (Linux Counter 282315)
A Texan in Denmark

That was patronizing, but that’s OK as I am sure you know linux way better than I do. I try not to do the same when I explain things I know to someone, but everybody has a different style.

As I said, I’m running Ubuntu and openSUSE on the same computer, and my experience is different then yours. It is true that one cannot generalize based on one or two samples, but there must be a good reason why every single article and review states that Ubuntu is easier to use.

IMHO your problem was you simply did not know what to do to set yours up, and rather than spend some time on this forum and IRC #suse trying to get help, you made an inaccurate assessment.

How much time would really be enough? It’s not like I never recompiled linux drivers to use them with with an updated Kernel (e.g., GPIB), or I never compiled an application that somebody else wrote, or that I never managed to get the multimedia to work. The only problem is that everything seems more difficult under SUSE then under Ubuntu.

And, regarding repositories, yes, I can go and read a great deal of articles, just to set up the eqiuvalent of Ubuntu’s defalut + medibuntu. Under ubuntu I had to enable: default ones + packman + vlc + science (for scipy, numpy, etc), then I had to run some custom made script to get the fonts. I’m pretty sure this is NOT so much easier to do then under Ubuntu.

Reply to some points:

  1. I did add packman, it did not help under Gnome, it did help under KDE.

  2. As I said, I did set all the repositories, but now I have to find all the packages that are both in regular and packman repositories and “upgrade” them.

  3. Why are you talking about “alsa”, when the problem with audio control was with “pulse”. The little “volume” icon was controling pulse, and it was not working.

>> I was spending 95% of my time teaching the Ubuntu users Linux basics. But without doubt, the VAST majority of users with sound problems in #alsa are Ubuntu users.

While I like to learn about OSs, I prefer to use them while steering away from MS at the same time. Why is it so important to know about internal working of a kernel to be able to use your computer?

I’m talking about IRC#alsa, NOT the application/driver alsa. I spent time on IRC #alsa trying to help Ubuntu users with their non-functioning sound. I think I made that clear.

If you want IRC help for your pulse audio, simply go to IRC #pulseaudio, although my experience is that is a very quiet IRC channel.

Who was talking about the kernel ? :confused:

You don’t have to read a great many. I can point you to one:
Repositories - openSUSE-Community

Looking at your post count I saw one post. It suggests you joined our forum just to rant.

So I think more than one or two rant posts would be necessary … a request for help with specifics would also help.

If you wish some help, please post, and myself and other’s will chime in. Else I’m going to recommend to my fellow mods that we move this thread to soapbox.

Hi ivom66,

Thanks for the review. Was an interesting read.

I can relight to your opinion of openSUSE not being as easy as Ubuntu. But I also take in account that you are coming from a place where you are known with many ins and outs of Ubuntu and have a basic idea of how to do things in and around openSUSE.

For me the experience was the other way around, I got to learn and love YaST and that put me off using many other distributions until I got the true basics of Linux… then it was a better comparison, but I still prefer openSUSE overall… it’s a matter of perspective I guess :wink:

For the multimedia, Ubuntu has an easy install, but so does openSUSE; Restricted Formats - openSUSE-Community

It’s your one-click stop to get things setup.

One thing that is amazing in openSUSE 11 (compaired to previous openSUSE versions) is the package manager. I can safely say it’s on pair with apt. Speed and ease of use are both there, and for me YaST again wins. But that is my preference.

I think if one would truly step in blank into Ubuntu, or step in blank to openSUSE… who knows which of the two would win. I think YaST is a big plus though.

In the end it’s about enjoying what you use and being to do what you need and want…

If you give openSUSE 11 a go, give it a bit more time to sink in and don’t focus to find specific Ubuntu trades in openSUSE. Do it the SUSE way :slight_smile:

As we say here : have allot of fun!


Open a bug report (with your camera model and so…). Who knows where the problem is, but the thing is that a window should pop up and doesn’t. So it’s a bug… be a good user and report it.
Probably is a specific problem with your camera… until someone with that same camera reports it the bug will never be fixed.

No idea what you mean with “restricted meta package”. If you mean the 1-Click link from… perhaps some more package should be added, if so report it. But looking into it with a text editor:

<!--        Gstreamer stuff -->
       <item recommended="false">
	       <summary>Additional GStreamer codecs</summary>
	       <description>Additional GStreamer codecs</description>
       <item recommended="false">
	       <summary>Additional GStreamer Codecs</summary>
	       <description>Additional GStreamer Codecs</description>
       <item recommended="false">
	       <summary>Additional GStreamer Codecs</summary>
	       <description>Additional GStreamer Codecs</description>
       <item recommended="false">
	       <summary>Additional GStreamer Codecs</summary>
	       <description>Additional GStreamer Codecs</description>
       <item recommended="false">
	       <summary>Additional GStreamer Codecs</summary>
	       <description>Additional GStreamer Codecs</description>
       <item recommended="false">
	       <summary>Fluendo GStreamer plug-in for mp3 support.</summary>
	       <description>Fluendo GStreamer plug-in for mp3 support.</description>
       <item recommended="false">
	       <summary>Fluendo GStreamer plug-in for MPEG Transport Stream muxing</summary>
	       <description>Fluendo GStreamer plug-in for MPEG Transport Stream muxing</description>
       <item recommended="false">
	       <summary>Fluendo GStreamer plug-in for MPEG demuxing.</summary>
	       <description>Fluendo GStreamer plug-in for MPEG demuxing.</description>
       <item recommended="false">
	       <summary>This plugin contains the FFmpeg codecs, containing codecs for most popular multimedia formats.</summary>
	       <description>This plugin contains the FFmpeg codecs, containing codecs for most popular multimedia formats.</description>

Which one do you think is missing? Note the ‘recommended=“false”’… perhaps you just forgot to check them? I have never used the 1-Click thing, but…

This one makes no sense at all. A package doesn’t installs libraries… not in openSUSE and neither in Ubuntu. That’s a task for the package manager.
The Packman repository is a good one. And I can say you for sure ffmpeg and all the needed deps are on Packman or OSS repository… so you just need to select it for install, the same than on Ubuntu.

There exists a bug with PulseAudio? I’m not surprised… it’s something new, it’s only used on Gnome, and there are less Gnome than KDE users in openSUSE to test it during the beta releases.
And so? Just report it and will be fixed.

About Ekiga… Ubuntu makes something special to help you to configure the firewall?

We are talking about Kernel Virtual Machine? I have never used KVM, so I don’t really know. But since a lot of packages have been patched to use ALSA this one should also… open a bug report.

This one neither makes sense. By definition, if you “find all the libraries”… that’s “enough”.
Anyway, to compile anything on Ubuntu you need all the libraries… the same on openSUSE. Sounds normal to me. zypper has the “source-install” option to find all the needed libraries for you.

I don’t use it and I don’t know why isn’t packaged anymore. Probably it’s because of patented codecs. Like in all these cases… Packman provides it. And it’s the same than ffmpeg… just say YaST PM to install it and all deps will be magically installed.

Today we have so good codecs because a lot of people investigated a lot to obtain them. To motivate them to continue investigating governs give them patents. openSUSE can distribute such codecs because of these patents (Novell isn’t going to pay for them to give them for free, and users aren’t going to pay for a openSUSE distro with patented codecs).
Hasn’t nothing to do with believing it is important or not. This situation is clear, and explained in at least ten places.

About “easy of use”… I suppose you don’t really expect an answer to that one.

If you want to help open bug reports where needed, this post doesn’t helps.
Perhaps you didn’t report a bug for your camera… but if it works on Ubuntu probably is because someone else did.

Sorry? You don’t have to upgrade them. If you want to, the package manager will select the latest verions automatically.
And if you do like me, that prefer official packages and only install Packman ones when have to… just set Packman with a lower priority.

Ok, thank you for all your comments. I will definitely give it a try, because in spite of my rants, the good things I mentioned in my first post are still interesting.

I can see that Kino is part of packman repository from Germany now. It wasn’t there before, and I only had the packman repository from Belgium (I think, not sure as I am typing this from Ubuntu).

As for the 1-click package, I did just that, I did not try to select individual packages. But looking at the same file through the text editor later, I found out what was missing.

Ekiga is not that important for me (I don’t use firewall under Ubuntu), so I am not going to bother with it any more.

As for KVM, yes, I am talking about virtual machines, and the configuration script wouldn’t work if it didn’t find all the necessary libraries. At least that’s what I think. I will try to post a bug, but I am not sure if that can be considered a bug, as I downloaded unsupported version 70 (supported version is 63). It’s just that I can compile it under Ubuntu (of course, after I downloaded proper libraries).


Here is an update, in case you are still reading this:

  1. ffmpeg works, its just that instead of -acodec mp3 I have to specify -acodec libmp3lame as the output of the formats gives me:

DE mp3 MPEG audio layer 3
EA libmp3lame libmp3lame MP3 (MPEG audio layer 3)
D A mp3 MP3 (MPEG audio layer 3)

  1. vlc doesn’t work, it says:

VLC media player 0.8.6h Janus
[00000285] main playlist: nothing to play
[00000285] main playlist: stopping playback

I have the latest version from the VLC repository. I tried to downgrade it to packman reposotory version, but that did not help.

  1. Totem works.

  2. KVM compilation:

a) I have the kernel-sources package
b) I prepared sources for the currently running kernel
c) I still get the following error message:

error: linux/compiler.h: No such file or directory
/home/ivom/Downloads/kvm-70/kernel/external-module-compat.h:12:26: error: linux/string.h: No such file or directory

Any ideas?

This can happen if you have not installed the codecs. Please ensure you have installed “xvid” and “w32codec-all”.

VLC and Packman repositories have some repeated packages. I try to use everything from Packman instead of VLC. Mix them can be really bad, specially since Packman VLC uses the dinamic library libavcodec that is really unstable between versions.

Not really an exhaustive list, but you can compare:

$ rpm -q --whatprovides $(rpm -qR vlc) | sort | uniq | grep "\.pm\."

About black windows and gstreamer output and so. If you have an Intel graphic chip you can test the updated driver I packaged ( Desktop Effects interfers with Video playback - Page 2 - openSUSE Forums ). If it works with the new version but no with the default one report the bug noting it.

No, since openSUSE uses version 0.63 you can’t report a bug because you can’t compile version 0.70.
But you have a 0.70 version available in the Build Service ( RepoView: KVM Kernel Modules and Tools (openSUSE_11.0) )
If that version still doesn’t uses ALSA report the bug against the Build Service package like “enhancement”.
Even if Build Service packages aren’t “officially supported” this package is from an Novell employee.

Edit: KVM 0.70 changelog says

  • enable ALSA


Thanks guys. I’m in a hurry now, but I will try the KVM and the “black screen” fix latter tonight.

As for the rest, I did a quick check, and:

  1. I have xvid and win32codec_all

  2. The output of command

rpm -q --whatprovides $(rpm -qR vlc) | sort | uniq | grep "\.pm\."

gave me only one line:

I replaced/downgraded packages with packman versions, and now I have the following output:

BUT, when I try to play a file, it says:

[00000569] dc1394 demuxer error: Bad MRL, please check the option line (MRL was: feb_17_2008.flv)
mdb:58, lastbuf:0 skipping granule 0
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  86
  Current serial number in output stream:  87

and a same message for avi files.

Can you point us to a sample (on the web) of the files you are trying to play, that don’t work?

I don’t know if its essential, but there is a packman packaged called “xivd” and “xvid4linux”. Try installing those packman packaged versions also, and see if it makes any difference. Also, install the Packman packaged “w32codec-all”.

oldcpu, RedDwarf:

I guess I started this whole thing with a negative review, but definitely one thing is for sure: you can get replies quickly on openSUSE.

I am not in front of my PC right now, so I cannot try anything before tonight. I am sure I will get the VLC working thanks to your and other people comments. And it is just a matter of principle (try to finish what you started), because I have no problem with using totem.

Here is something I do know:

  1. I did install xvid and win32 codecs, I am just not sure right now if I installed vlan or packman version.

  2. By inspection, I can see that I do not have the same list as you (, While I have these libraries, they are from vlan, not from packman, so they don’t have the ‘.pm’ suffix.

So, I will try to replace/downgrade vlan packages with packman ones.

Please note that I am repeating the word “downgrade” as that is what happens here. Vlan repository has newer versions of apps/libraries when compared to packman, and since I have a mixed bag of packages (some are from vlan and some from packman), that may be the cause of the problem. Maybe the easiest thing would be to do a clean re-install, I am not sure.

In any case, I believe that a good step forward would be to somehow synchronize these repositories, or to avoid duplicated packages.

In one of my previous messages I called a 1-click package a metapackage. It was my understanding that if a package contains a collection of other packages, it represents a “metapackage”. But, since I am not very knowledgeable in the package terminology, I thought I could at least explain what I meant.

** DenverD **
Thank you for your reply. I will try to stick a USB key and see what happens. I do not expect problems there.

There is a remote chance that part of my problems is caused because I am sharing a /home partition between Ubuntu and openSuSE. Maybe there are some gnome settings that are different.

** Magic31 **
Thank you also for your reply. I agree with you that yast package manager is a good thing, and fast enough.

One welcome improvement over previous versions of openSUSE in 11.0 was better packaging of programs that consist of several pieces. An example that always comes quickly to my mind is gvim. It used to be that under openSUSE you had to install several pieces, otherwise you get an application without menus or some other missing piece. With the new version, you install one packages and it “knows” to get all the parts of the program.

Those BadAlloc and XVideo sound bad. Can I suppose this only happens with compiz activated and only on an intel graphic chip?
If so, perhaps they will be fixed with the updated driver, but who knows (but if on Ubuntu works…)

The thing is Packman is a repository with a long story on openSUSE. You have the pretty web page to search for packages and a mailing list to report problems…
The VLC repository is something more of a mistery to me. Not sure who manages it or anything else… And since Packman has more packages makes more sense to install libraries from it since more packages are compiled against those libraries.
Since nearly every package (all but gtkstyle and libdvdcss?) from VLC is also available at Packman the VLC repo isn’t really very usefull. I only have it because libdvdcss… but for just a package you could easily install it manually and forget about the repository.

I don’t think a reinstall is needed. Just filter by repository in YaST PM and verify packages one by one… are just a few.

Note that VLC and Packman repos use different schemes for version numbers. When VLC says his libffmpeg0 is version it means it’s the 13782 revision from SVN. Packman instead of revision number uses dates. VLC version number can be higher than Packman without being really a newer version.
Also a thing is the version number an other the release number. lame 3.97-4.1 isn’t newer than lame 3.97-1, both are version 3.97… the 4.1/1 only make sense inside the same repository.
But yes, I saw some packages more updated on VLC. I think they are only: faad/faac (2.5 vs 2.6), libmpeg2 (0.4.0b vs 0.4.1) and perhaps libdca0 (but Packman has the latest stable version). I will ask about these two at Packman mailing-list…

I don’t think Oxford (or whatever the english language authoritative entity is) has said anything is this respect :wink:
Other distros only have metapackages in the sense of an empty deb/rpm with bogus dependencies, that’s the classic meaning of metapackage. openSUSE also has “patterns” and 1-Click links… I would not consider calling them metapackages wrong, but neither absolutely clear.

RedDwarf has a good point. ivom66, if you can go into the setup with each of the applications (mplayer, vlc, xine-ui, … etc … ) and change to X11 for video, it may work with Compiz.

I am happy to report that everything works now:

  • KVM with alsa (v.70) works
  • Kaffeine works
  • VLC works
  • USB flash drives - work
  • Digital camera - the window does not pop up, but the cammera icon appears on the desktop and if I click on it it offers me to start F-spot to import pictures. Good enough for me.

Now to elaborate, just in case somebody else finds this useful:

Kaffeine started working even before I installed updated video driver, as soon I selected X11 for video output, as per oldcpu suggestion. I think I found one or two home videos with somewhat choppy audio, but the rest of the videos played nicely.

VLC started working after I removed VLC repository and switched completely to packman. I had a problem with audio, and it started working when I selected OSS audio output. I find this strange, but it works.

Updated video driver: I don’t know if it helped or not. After I installed it and restarted X server my desktop background went totally black. I restarted it again, and this time everything seems to work fine.

Many thanks for your persistent help. I’ll probably spend more time on openSUSE now as it has some newer applications than Ubuntu. I can start using it now that I don’t have to play with the setup anymore. Except for Ekiga maybe, I have to figure out how to setup that firewall properly :slight_smile: