[opensuse-packaging] Easter and Milestone 5

A heads up from the mailing list…

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 16:36, 3 users, load average: 0.23, 0.25, 0.26
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

This in particular was of note to me:

Note that M5 will bring a new Xorg and a new kernel - and a lot of people have vacation around the holidays, so if you don’t make it, there won’t be time for extra hand holding.

I’ve been experimenting on my sandbox install with latest Xorg. Could not get the latest NVIDIA driver to work. Will install M5 in the sandbox as soon as it hits the repos, to see what it will do. IIRC the driver would not agree with the Xorg or MESA version.
Kernel 2.6.34 rc’s have not given any trouble so far.

I should have added, this is also important:

And for those that keep wondering about milestones: Milestone 5 is the last release before we head into feature freeze. After it I only allow leaf packages to be updated - including a text freeze for all of it.

Was this with your nVidia 9800GT card or your GT120M nVidia on your laptop? Was this the “nv” or the “nouveau” driver or the “proprietary” graphic driver?

I was able to get the “nv” driver to work with M4 on my sandbox with which has an AGP card nVidia FX5200, but its resolution was not good and I was not able to tune it with sax2 (as sax2 always failed). I wrote a bug on Sax2 that has purportedly been fixed.

I was also able to get the proprietary nVidia driver to work well with M4.

I’m doing most of my openSUSE-11.3 milestone testing with LXDE desktop, although I probably need to take a temporary stop on this LXDE testing now, and test the applications I plan to use on KDE4 before we get too deep in the milestone freeze process.

On both…:). I have a spare 30GB SSD for sandboxing. Should have explained that. This was on M4 with latest Xorg packages from the Xorg repo.
My point was that the propr. driver compiles, installs, loads, just did not work with latest Xorg. Since the install was too experimental IMO, I did not report, but the messages were clear: Xorg and NVIDIA driver would not cooperate. I was expecting the new Xorg to appear in M5 and wanted to try and see what I would meet.
The ‘nv’ driver worked on both, just not in the proper resolutions
The ‘nouveau’ driver worked on the laptop, even KDE4, no compositing but superfast, not tested on the server.
The ‘nvidia’ driver worked on both machines, before upgrading Xorg.

Would the new Xorg be refering to version 1.8 of X Server? This is from Phoronix:

X Server 1.8 with its HAL replacement and new configuration system can be found in Fedora 13 and openSUSE 11.3 once released.

I can’t seem to pinpoint what version of X Server openSUSE Factory is at.

In openSUSE factory, there is currently xorg-x11-server-7.5_1.7.99.902-2.1. I believe this is X server 1.8 RC2. And xorg-x11 will be 7.5 in 11.3.