openSUSE on VirtualBox-xinit failure

When installing openSUSE Leap 42.1 on my virtualbox, and on the immediate boot after installation, I have a proper gui that works fine. When the vm is shutdown and restarted, when booted back up, I receive only the command line. I’ve tried running startx but alas, I still get errors.

(==) Using config file: “/etc/X11/xorg.conf”
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
Fatal Server error:
(EE) no screens found(EE)

VGA Arbitration: Cannot restore default device.
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: connection refused
xinit: server error

xinit failed. /usr/bin/Xorg is not setuid, maybe that’s the reason?
If so either use a displayer manager (strong recommended) or adjust /etc/permissions.local and run “chkstat --system --set” afterwards

So I’ve tried to setuid Xorg but I still get that no screens found issue. Is anyone able to help me, I’m rather new with Linux, let alone openSUSE.

Any particular reason for an xorg.conf?
Maybe that’s what’s causing your problem, try to remove or rename it.

If that doesn’t help, please provide the whole log file, /var/log/Xorg.0.log.