OpenSuse on USB Flash drive

Hi, I am a total newbie. I have heard a lot about OpenSUSE and decided that I would like to try it, so I have made a live CD of version 11.1. I have been trying to install it on a USB flash drive so that I can save any changes and things like my bookmarks and e-mail settings.

I have booted my computer with the live CD and have been following the method described in Boot and run Linux from a USB flash memory stick | USB Pen Drive Linux but keep running into trouble.

The capacity of the USB flash drive is 4GB. When I start the installation all goes well until the actual installation; before that the ‘Suggested Partitioning’ is:

Delete partition /dev/sda1 (509.84 MB)
Delete partition /dev/sda2 (3.22 GB)
Create swap partition /dev/sda1 (509.88 MB)
Create root partition /dev/sda2 (3.22 GB) with ext3

I think it is deleting the two partitions because I have tried the installation twice before.

When it has collected all the data (i.e user name etc and the partition data) it gives a summary of what is going to happen so I click on “Install”. The installation begins and is followed almost immediatelu by an error message “Failure occurred deleting partition /dev/sda1, Error code 1014”

When I try a second time the “Suggested partitioning” window now says:

“Create root partition /dev/sda2 (3.22 GB) with ext3
Format partition /dev/sda1 (509.84 MB) for swap”

This time when I click on “Install” in the Live Installation Settings window I get another error message:
“failure occurred during following action: Formatting partition /dev/sda1 (509.84 MB) with swap. System error code was 3008
/sbin/mkswap ‘/dev/sda1’
/dev/sda1: Device or resource busy”

Can anyone help me with this problem, please?

I should have mentioned that the method described in www.pendrivelinux says it is for the KDE version, but I wouldn’t have thought that it would make any difference that I am using the Gnome version.

First suggestion is to not use a swap drive - it’s completely unnecessary for the stuff you’ll be using a USB test / recovery installation for.

Second, have a go at using the partitioner on the live CD to completely delete the partition table on the USB before you start again.

It’s difficult, but it can be done. If you want to cheat your way out, you can download an unofficial KDE 3.5 live USB, which I believe is persistent…

Thanks confuseling. How does one avoid using a swap drive? I don’t remember seeing an option about it. Also, at my first attempt installation program offered the possibility of deleting all partitions so I accepted that thinking it best to start with a ‘clean slate’

By the time I had posted my message, I had already had three attempts at installing it, so I don’t know what state the drive is in now. I had assumed that each attempt would have wiped all partitions off the drive but perhaps that is not the case.

If you let the partitioner decide how to arrange things it will put a swap drive in. You need to make absolutely sure you know which drive you’re installing to, then during install select ‘custom partitioning’, delete all partitions on the drive, and mount it as one big partition mounted as /, probably in ext2 to save wear and tear. You’re right - this process should destroy the partitions already there, but your first post seemed to indicate a problem, presumably just with the way the partitioner is trying to set things up, but potentially with the partition table - I was trying to obviate that possibility.

Try the custom set up, and just mount one partition, ‘/’, in ext2. Hopefully, she’ll fly… :wink:

Many thanks for your help, confuseling. It all seems to work OK now. However, although I said that I followed the method in Boot and run Linux from a USB flash memory stick | USB Pen Drive Linux, I found that what was appearing on my screen was totally different from what was on that web site. Perhaps that method refers to a different version of OpenSuse. Anyway, I just clicked on the installer and let it run its course.

I have one last very minor problem and that is when the pen drive is booting, there is a long list of what is being loaded and what is going on during the boot. Is there a way of stopping that so that it boots straight into the desktop without all the spiel? I noticed that when booting from the CD there isn’t all that so presumably it can be stopped?

I believe that Ubuntu has a file called ‘menu.lst’ which can be edited so as to give a quiet boot so I tried to run gedit with a view to looking for a similar file but gedit says it couldn’t open my display. Perhaps there is a different editor in OpenSuse?

I would think that “gksudo gedit /boot/grub/menu.lst” would work.

If not maybe try
“su -
gedit /boot/grub/menu.lst

If not something’s up! There’s always vi… :wink: