OpenSuse on Samsung ARM Chromebook: it almost works...

Here my experience with installing OpenSuse on a Samsung ARM Chromebook:

Before this, I tried a lot of installations: Ubuntu, Kali, Bodhi, LAMP, Fedora, Linuxmint, ARCHLinux, crouton-versions. And most of them are incomplete or did not work at all.

If you are interested: here are some links:

Installing Arch Linux with XFCE on the Samsung ARM Chromebook | craigerrington.com

Arch Linux ARM • View topic - ALARM on Samsung ARM Chromebook

Install Fedora 17 on Samsung Chromebook Series 3 (ARM)

How To Install LinuxMint on Your Chromebook Pixel

How to update Chrubuntu 12.04 to Ubuntu 13.04 | Marcin Juszkiewicz

http://www.chromebook-linux.com/2011/11/speed-up-ubuntu-on-chromebook.html

Ubuntu + Cinnamon - A good idea? No. A great one.

Chromebooks and Chrome OS

These all all solutions with dual-boots. But there is also a way to integrate ChromeOS with Linux: https://github.com/dnschneid/crouton#readme

So, yesterday I installed OpenSuse as I found it here: https://www.berrange.com/posts/2013/03/31/automated-install-of-fedora-18-arm-on-a-samsung-google-chromebook/#running

A very simple action. But…no mail and no websurfer. So I searched for a Software Center to install Firefox and Thunderbird. And found Instellingen → Install/Remove Software.
It starts and then I get this message: "UI Syntax error. Couldn’t load plug-in gtk-pkg. Check the logfile "

In this topic https://forums.opensuse.org/english/other-forums/community-fun/general-chit-chat/486590-samsung-chromebook-arm-web-browsing-2.html you’ll see how Miuku helped me until now. Thanks to him it’s almost finished. Hope he will help me to complete the installation…

Bart

ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR-ERROR

In the topic above I said:

This must be:

So, yesterday I installed OpenSuse as I found it here: https://en.opensuse.org/HCL:ARMChromebook

Bart

Looks like yast is not having all it needs. Is yast2-control-center-gnome installed? IIRC that’s the one that pulls in the gtk stuff. But, this not on ARM.

gtk-pkg is in libyui-gtk-pkg4

Cool.
And you’ve found the HCL page which as you note should be your main resource.

But, for anyone interested in doing this, I’d generally recommend testing in a VM first, and you should be able to do this using qemu-system (yes you can can emulate non-x86 hardware like ARM). To avoid window manager conflicts I haven’t been able to resolve using a console, you may need to do this on an openSUSE host without a Desktop installed or remote into the machine using something like VNC.

For help here, you may need to post the results of the following

zypper lr -d
zypper info yast2

Try running yast in ncurses mode (console without the “2” in the name)

yast

And, immediately after failure

tail -n 50 /var/log/messages

TSU

Hi Bart,

To eleborate after your email:
The software installer is complaining it cannot find the gtk-pkg plugin.
Since my Software installer works, I told it to search for ‘gtk-pkg’, found it’s not a package, so I extended the search to files in the packages, which gave me the package above.
You could install the package from a terminal window, by doing


su -c 'zypper in libyui-gtk-pkg4'

use the root password when prompted for. Accept any dependencies that zypper may want to pull in. Then try the software installer again.

@tsu2:
Thanks for your help. I did what you said, but now I have to get the results on my pc and I have to figure out how to do that (mount a usb-stick). As soon as possible I will give the results here.

@Knurpht:

Your code:


 
su -c 'zypper in libyui-gtk-pkg4'

helped … a little bit.:\

After having rebooted I choose install programs. And then I can choose ( but still no Firefox or Thunderbird there).
But when I click on Apply , the screen disappears, and nothing has happened…

In the mean time, I’ve read that Wine does not work on Arm processors.>:(
And because I have some Ms-Access applications that are important for me, it has no sense to go on experimenting with the Chromebook. So I will sell it.

Thanks for all help!

Bart