OpenSUSE on EEEPC 1000

I’ve made a similar post in the Laptop forum and thought i’d also put my question into this forum.

I was wondering if anyone has successfully installed OpenSUSE 10.3 or 11.0 on EEE PC 1000. I am looking at buying one and would like to know if there are any gotchas with installing OpenSUSE on it.


Hi. I have the eee701 but i think the hardware is the same. I did am install of 10.3 but i was not satisfied. Too slow and the wifi atheros needed a patch to work. Never tried os11. Even if i am an entusiast of Suse back to the times of 7.3 i at the end installed Mandriva spring 2008 that works out of the box and on that hw is much faster. If you decide to try os11 share your experiences maybe i’ll change

I got 11 installed with KDE3.5 and it’s fine…except the dang network attansic card and wifi don’t fly.

I ordered up a intel pro wireless ABG and will replace the ralink card with the intel. That should make the wifi work with native drivers.

The attansic card for the wired network sucks! I have compiled the atl2 drivers for it and still can’t get it to go. It shows up after installation in Yast, but you can’t configure it and you can’t delete it either. Frustrating.

Mabey once the intel wireless is in the machine I can get the updates online and see if I can get atl2 to work.

Everything else works!!! I hate weird hardware. I love the machine but these off-the-wall network chips are crap!

I found this on the Ubuntu site:
*"Solved !!!
Hi Guys

Thank you, thank you so much !!!

I have got it working !!!

Ok first the network card is Atheros(R) AR8121/AR8113 PCI-E

Ok these are the steps i followed to get it working!

  1. I installed ubuntu hardy 64bit, i has build-essential package installed
  2. Then i downloaded the linux driver from:
    (as per my original post)
  3. I then transfered the driver via usb stick to my laptop and unpacked the zip. (Actually i unpacked it on windows first as it has a .rar file that i could not unpack on linux Then i packed it up again on windows).
  4. cd into <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src
  5. then i ran: sudo KBUILD_NOPEDANTIC=1 make
  6. then i ran: sudo KBUILD_NOPEDANTIC=1 make install
  7. that worked and put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/at1le.ko
    8 ) i cd into that director and i run: sudo insmod ./atl1e.ko

That is it !!! it worked as soon as i plugged in network card.

Thank you all so much !!! I hope this helps everyone else"*

For SUSE I found the Kbuild, and unrar in the software manager and installed it instead of the build-essentials. Other than that, I did the same thing line for line. I used the unrar to unpack the .rar file that pops out of the zip insteat of using windows.

I also used su instead of sudo because sudo couldn’t find insmod for some reason.

Ok, here are the links I found for the RA2860 wireless card:

¹p­â¬ì§ÞªÑ¥÷¦³­­¤½¥q: Technology](

Make sure your BIOS has the Wlan turned on. You might want to turn the camera and the bluetooth on too while your at it.

Unpack the driver and open the folder. Hit F4 and run su.

make clean
make install

Now browse to the /lib/modules/<your kernel>/kernel/drivers/net/wireless/

rt2860sta.ko should be here. Run “lsmod rt2860sta.ko”

Weeeeeelll I got this far and It shows up in Hardware Info, but not in Network Devices!!! This is one screwy card. I’ll follow up here when I figure it out.:stuck_out_tongue:

So. ra2860sta.ko sets itself up as ra0.

I’m trying to figure out how to get it to work as wlan0 instead.

There are some cryptic instructions for wpa_supplicant and such included in the readme with the source. I’m not sure yet what changes to what files are needed in order to compile the right driver, or to get it looking like wlan0 or both.

alias dosn’t work to alias ra0 to wlan0.
iftab doesn’t work because the mac address is unknown. ??
udev rules also require a mac address.

I think that changing the source might be the best bet. Get it to setup as wlan instead of ra from the start. I’m gonna have to yak at some code gurus to get this done.

I’ll post the changes here when I get them.


Anyone had any luck with this?

OK! I replaced the ra2860 with an intel pro ABG and viola! Internet via wireless.
Had to re-install wpa-supplicant and update everything using the atl1e eth0, but after that, and reloading network manager, away it went!
Got the sound working by opening yast/hardware/sound and using the advanced button opened volume and turned the “front” channel up. DUH! It’s 0 by default! Oh, and I set the master channel in the KDE volume control to!

Next is the camera…

Used Yast to re=install the uvcvideo and it updated the kernel.

Bang! No more wifi! Turns out the new kernel uses a new wifi stack! Plugged in the cable, went to intel to find the driver and found the compatibility drivers for mac80211 type cards for the new kernel. I have 2.6.25 so I got the appropriate compatibility sources and “make” “make install” “make unload” “make load” “modprobe iwl3945”.

Had to power off and remove battery for the card to come back. But I’m back on wifi!

Now to test the camera…

Lots of things have changed. I updated the BIOS to 1005 and now the PCIe wifi card shows up in both Suse and XP.

There was a problem related to sleep, or so I thought, but it was a card init problem in the BIOS.

The souund works, but not the MIC. The camera works with updating uvcvideo in Yast.

Skype and uvcview both work the camera fine but not VLC.

The only thinggs not working yet on this machine are the special keys, the MIC, and the ra2860 wifi card. My intel Pro ABG card is working fine.

Hey slappyobonobo!!

I should have seen your posts before I got my Eee PC 1000 with SUSE 11…


I am stuck trying to get Eth working.

I found an atl1 driver in my lib/modules/…kernet/net/drivers but i guess I need atl1e or atl2 driver isnt it??

What is the status?

Can you help me?

did u get yours working??

Not Yet. I swapped my ralink card out for a intel that I got on ebay for 20 bucks. That works fine right off! The ralink uses a Marvel TopDog chip that ought to just be called DumbDog! Even on windows, the chip has poor performance and reliability. The intel wifi works great and is the same one that is used in the IBM/Lenovo Thinkpad. I got the A/B/G capable card.

If you swap it out, be careful of the antenna connections. One is white and the other is black. They snap on and are very tiny! Use needle nose pliers and a magnifying glass to make sure you don’t bend up the connectors.

I found another linux that was built specifically for the EEE. Havn’t tried it yet.

I havn’t gotten the microphones working yet either. not sure what to do about that. The chip seems to be fairly standard but the mics don’t work.

oh i see. thanks!!

From what I read, that was fixed as of 1.0.17 of alsa. What alsa version have you installed? I have read sometimes (even with 1.0.17 installed) the auto probe of alsa was not sufficiently accurate to configure for the internal mic, and users had to apply custom settings.

There are rpms one can install to update alsa to 1.0.19.