opensuse not recognizing external hard drive

hello everyone,

im new to linux and i was having trouble getting linux to recognize my western digital removable hard drive, i tried dmesg, it sees the drive, so it knows its there, i just dont understand why it wont come up as a plugged in device.

also, im on opensuse 11

First check in the folder /media
that your device is not there

Also tell us what desktop you use ie;kde3…

How is the device formatted?

I had a external that didn’t work with linux until I booted it on a windows machine, then booted back on my linux machine, it worked fine then.

I have 3 external USB Western Digital hard drives with ntfs partitions that could not mount on my OpenSUSE 11.0. After much searching and hair pulling, this is what I discovered. First log-on to a terminal window as su and type the following command: /sbin/fdisk -l, this will give you a list of all of your drives. If you see your USB drive(s) on the list, then you know the system recognizes their presence. Next make sure that the ntfs-3g utility and the FUSE package are installed on your system. Next log in to a terminal window and type the following:ln -s /sbin/mount.ntfs-3g /sbin/mount. ntfs, this will create a logical link to your USB drives. You may not see any changes, but you also shouldn’t see any error messages. Reboot the system and open up my computer, you should see icons that look like USB flash drives with little green arrows pointing at them. The little green arrow means that the partition is mounted. You can also check your start menu under computer and see if the icons appear there by scrolling down. You can also check your Media folder to see if anything appears there. If you see what I described, you should be able to access your ntfs partition(s). CAUTION: DO NOT shut down or reboot the system without unmounting those partitions first.If you do, you will NOT be able to log on to a desktop. Your MBR will become corrupted and you will have a serious mess.You can unmount the ntfs partitions by right clicking on them in my computer or start menu/computer and selecting “safely Remove”, that should do it! If you damage the MBR files, you can restore them by getting a copy of Linux Mandriva 2008.1. It has a rescue feature that will restore your Windows MBR if you’re dual booting your system. You will have to re-install your SUSE over again from scratch. There is probably a better way of doing all of thesse things, but this is what worked for me. Just one more thing, if you can’t see your USB partitions after completing these steps try unplugging the USB drive and plugging it back in. If you get a pop-up window like you would for a CD-drive, just select “do nothing”, tick off the “do this for all this type of media”, and click “cancel”

With risk of being a little OT, but Im getting a bit desperate:

I have a similar problem but with a now filled USB stick with some 7 Gb data I dont want to loose…
I have formatted it in one SUSE 11.0 computer for FAT and used it some times without problem.
I wanted to transfer also one big file (The DVD.iso for SUSE 11.0…!) and when ready I didnt want to wait for the long time it takes to send the file to trash, so I decided to instead reformat the drive by yast partioner.
Again FAT and then it came up directly as a new connected disk, which I filled wiht new data for the other computer I’m changing to.
Problem is only now that the USB-stick is not recognized at all by any of my two SUSE 11 computers…
I saw in other thread and here some tips of how to find the fault and did:
magnus@linux-g3hq:~> su
linux-g3hq:/home/magnus # mkdir /media/usbdrive
linux-g3hq:/home/magnus # mount -t vfat /dev/sdb1 /media/usbdrive
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

linux-g3hq:/home/magnus # dmesg | tail
atkbd.c: Unknown key pressed (translated set 2, code 0xa9 on isa0060/serio0).
atkbd.c: Use ‘setkeycodes e029 <keycode>’ to make it known.
atkbd.c: Unknown key pressed (translated set 2, code 0xa9 on isa0060/serio0).
atkbd.c: Use ‘setkeycodes e029 <keycode>’ to make it known.
atkbd.c: Unknown key released (translated set 2, code 0xa9 on isa0060/serio0).
atkbd.c: Use ‘setkeycodes e029 <keycode>’ to make it known.
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC= DST= LEN=169 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=149
SFW2-OUT-ERROR IN= OUT=wlan0 SRC= DST= LEN=40 TOS=0x00 PREC=0x00 TTL=64 ID=18104 DF PROTO=TCP SPT=28853 DPT=80 WINDOW=114 RES=0x00 ACK FIN URGP=0
FAT: bogus number of reserved sectors
VFS: Can’t find a valid FAT filesystem on dev sdb1.*
linux-g3hq:/home/magnus # /sbin/fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x11a8ba38

Device Boot Start End Blocks Id System
/dev/sda1 1 764 6136798+ 12 Compaq diagnostics
/dev/sda2 * 765 2984 17832150 7 HPFS/NTFS
/dev/sda3 2985 14593 93249292+ f W95 Ext’d (LBA)
/dev/sda5 6054 6266 1710922+ 82 Linux swap / Solaris
/dev/sda6 6267 8877 20972826 83 Linux
/dev/sda7 8878 14593 45913738+ 83 Linux
/dev/sda8 2985 4212 9863847 83 Linux
/dev/sda9 4213 6053 14787801 83 Linux

Partition table entries are not in disk order

Disk /dev/sdb: 8086 MB, 8086618112 bytes
255 heads, 63 sectors/track, 983 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x04dd5721

Device Boot Start End Blocks Id System
/dev/sdb1 1 983 7895916 c W95 FAT32 (LBA)*

Seems to be something wrong with the FAT…
Please…I dont want to loose this data…are there any way to recover this USB-stick?

unplug the external drive
list the drives
plug it in list the drives
the diference between the two will list your drives as the diference between the two

Well, thanks for Ur sugestion, but the Stick is without a working filesystem according to WXP either. It asks if I want to format it…
But…I come to think of the eminent program Testdisk + Photrec:
TestDisk Download - CGSecurity
This really an amazing software!
I manged to get out a rawfile of 7.5 Gb with testdisk, out from which Photorec could extract just about every file there was!!
jpeg, mp3, avi and directories.
Only problem is that mp3 + jpeg lost their original filenames, but thats easy solved by Easytag or similar software.

Well well, have to be more careful when I format a USB next time…
Strange that it was possible to write to it anyway…

problem solved