Opensuse: no mp3 and no sound in flash

Hello there,
I just installed opensuse 11.2 and im having problems to play mp3 files and sounds in flash apps played in firefox. About the mp3 problem, i tried to find a solution around the internet, but nothing works and i dont even know if i really have installed the codecs to play this format here. Anyone knows how can i install the mp3 codec? i tried using another player too instead of amarok, like songbird, but he doesnt work as well

About the flash apps problem, is strange that flash works fine with konqueror, but not with firefox. The images in youtube for exemple play fine, but have no sound at all! i read something about a problem with kde4 causing this, but i didnt find a solution. Anyone have any clue about this??
thanks alot

Try this for mp3.
Open YaST -> software repositories -> Click Add (button) -> Choose Community repos -> Click next and Choose Packman -> Finish.

Now go to software management in YaST, and search for Vlc, smplayer and mark them for installation separatly. Click Accept button after that.

Now play your mp3 files.

Thanks, now i can play mp3 with smplayer, but not with amarok. How can i configure it to play too??

add the xine-codec package from the packman repo

dth2 wrote:

> add the xine-codec package from the packman repo
I might be wrong but in yast–>software management search on amarok then
click the ‘versions’ tab. Make sure that the version you’re using has ‘pm’
in the name. I had some problems on a machine with amarok not playing mp3
files too and ensuring that I had the packman version of amarok installed
solved the issue.