openSuSE networking not working on Acer Netbook!

While installing the openSuSE on my Netbook (Acer AspireOne D250) with a bootable thumbdrive Live image, the installation seemed to go fine, but after the installation was completed, there was no “network”! I checked and the system auto-sensed the drivers, but when I go into the network, even trying to manually set up the IP info, Yast reports NO NETWORK running!!

I then went out and bought a USB CD-ROM drive and installed using the boot CD (Network install) on the external USB CD-ROM drive. It booted up fine, and installed “RIGHT OFF OF THE NETWORK”, but when the install was through, I could not access the network. Same error: NO NETWORK RUNNING!!

Now I’ve installed openSuSE on this unit before (v11.4) and it worked fine (after I changed the wireless driver to the legacy driver) but this time it’s NOT working!!

My 13yr old son uses the Netbook, and was so excited to get to use LINUX instead of Windows … until now.

H E L P !!!

Richard A. Allcorn

Netbook: Acer AspireOne D250, 2GB RAM, 250GB hard drive, extended life 8hr battery.

rAllcorn, welcome to openSUSE Linux and to our forum.

This post appears to be more a Networking issue than an Installation Issue. Hence I am going to move this thread in the next hour to the Networking area of our forum. ** I ask that both NNTP and webbased users do NOT reply to this thread until AFTER the post is moved.** I’ll leave a link here for a week for WEB based users.

I will post to this thread (in networking) quoting your post AFTER the move is complete.

Thankyou for your patience.

While waiting for the thread move, you could check out YaST > Network Devices > Network Settings and see if you can configure this pc’s network settings there.

This thread has now been moved from “installation” area of our forum to the “networking” area of our forum.

The thread is NOW open and I invited both our NNTP and web based users to respond and assist in solving the problem noted in this thread.

Thankyou for your patience during the thread move.

rAllcorn please advise if you need more guidance than that brief suggestion. Note YaST is an administrator application on openSUSE.

On 06/08/2011 09:06 AM, oldcpu wrote:
> rallcorn;2350465 Wrote:
>> While installing the openSuSE on my Netbook (Acer AspireOne D250)

sounds like pure bad luck to me!

i say because after running the 32 bit Live CD of 11.4 with KDE i fresh
installed the same mix from DVD, while the machine was wire connected to
the network, and when the initial install and update/boot was finished
then networking “just worked” on my Acer Aspire One D255…

just worked! until i pulled the network wire out and then all i had to
do was enter my wireless password/ID credentials and wireless “juts

well, the only thing about the network which is less than perfect is if
i now boot up with the wire attached and later wanna walk the machine
into the yard it doesn’t automatically switch from wired to wireless…i
have to spend the extra 3 seconds needed to click on the network manager
icon on task bar’s “Enable Wireless” selection…

now, i fully recognize i’ve helped your problem one bit–i’m sorry i
can’t lay out a path for you because mine was trouble free…i give you
my story to encourage you to keep going, because there IS a smile
available for your 13 year old, somewhere…keep trying…

OH! maybe this will help you:

via NNTP openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10
Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics

  • When your gecko is broken you have a reptile dysfunction! *

openSuSE should install and run fine on your Acer.
Have you checked the nework manager icon to see if the network is available to all users and is set to automatic connection?
(Right click the icon and …Edit Connections)

If this fails, go to yast2>network and set the network to use the traditional ifup and configure it there.
Once configured and working, you can go back to using network manager.

Rich here:

Just today (10-JUN-2011) I re-installed the unit again, this time using the NETWORK INSTALL.
It works! The NETWORK “works”!! (after 3 or 4 installs of various types). They must have fixed something on the install end (network install).

Now, when trying to go to the network and setup the wireless (requires fall-back to legacy) I cannot get into the network setup, but I’ll take this one step at a time.

This is a real problem, and apparently not just with mine. I saw this issue all over the NET (Internet) so there must be something that caused it for “all” (or most) Acer and/or Netbook users.

Click the Suse icon and choose Yast. Enter the root password. You will find the network settings in the network Devices> network card section.
You can now change to ‘Traditional with ifup’ or ‘network manager’.
If you are connecting to multiple wireless networks, use the network manager and set up the wireless for each of your wireless networks. (right click the icon in the toolbar after the change.
Sorry not using 11.4 on my acer so don’t know if there are problems. 11.1 to 11.3 all worked fine on my netbook.

Ok, “THIS RE-INSTALL” using the NETWORK INSTALL CD was successful and the networking (wired only) WORKS! However the Network Manager was not loaded. When I used YAST to go into the network hardware to configure it, I get an error …

/sbin/yast2: line 423: 13603 Bus error $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

and I cannot get into the network setup, through YAST … either using the YAST in X or at the command level.


I still need to get the wireless working, and both moved over to the Network Manager.

We’re getting there … slow but sure!

It looks like something is missing in the install.
Have you tried updating the system and then setting the network?

Also, on install, if you uncheck the ‘automatic configuration’ box (It’s on one of the last windows before the install starts), you can set up the network manually.

Did the live version run on the acer? If the live version runs, you should be able to install without a problem.
To create a usb or sd card live, make sure it has no data on it and use the dd command to create it.