openSUSE mic fails to record in some applications (but works in others) - suspected bug

Under the application guvcview, the microphone on my Lenovo X1 Carbon on openSUSE-15.3 fails to record. I went to pavucontrol and ensured the laptop’s mic (identified as a digital mic) was selected. Both guvcview and pulse audio record bars move back and forth dynamically indicating the audio is being received, but inexplicably it is not being recorded.

I note that if I run a basic

arecord -d 30 -f cd -t wav test.wav 

from a bash shell, the record works properly.

I note the microphone is not working in guvcview. I think this is similiar problem to what was reported in Tumbleweed. Reference here:

The record failure in some apps (per that Tumbleweed bug report) is not hardware specific.

Bug report is here:

I will likely either write a new bug report on this or report it in the Tumbleweed bug report that problem also exists on openSUSE-15.3.

For this Lenovo, I am using the sof-firmware that is packaged with openSUSE LEAP-15.3 (v.1.6.1-2.9). I might install the newer sof-firmware v.1.8 that is in the Experimental repository, but I don’t believe that to be the issue.

I think this to be a known openSUSE bug, possibly introduced as part of the implementation of pipewire (my speculation).

I’ll update this thread if I learn any more.

Try to use the latest pipewire - it is under heavy development now

  • the newest ALSA + something else?

I have same symptoms with guvcview on Tumbleweed on a desktop PCwith latest pipewire/pulse, so I am reluctant to do so with my laptop until the desktop is shown to work.

I note I was able to record audio with my Lenovo X1 in Firefox using a WhatsApp page … so I believe that this Lenovo X1 carbon audio issue with guvcview is app specific with guvcview (and some other webcam apps) with LEAP-15.3 and Tumbleweed.

This could be an application problem, I am using tumbleweed and guvcview and webcamoid can’t record the audio.
It’s only cheese that can record an audio when using video recording. I tried this using pipewire and then when I switch back to
pulseaudio. It was a good timing for me to test both in pipewire and pulseaudio because I was really planning to go back to pulseaudio
because I can’t make the simultaneous sound work using pipewire.