openSUSE messing up my windows partition, somehow.

I’m trying to dual boot windows XP and openSUSE. First, I install windows from the installation CD on a 10gb partition. It works perfectly. Then, I boot to an openSUSE liveCD. I run through the install with all the default settings. Nothing in the partition section appears to be messing with the windows partition. Then, I run the install, reboot to windows and get an UNMOUNTABLE_BOOT_VOLUME error. Is there any way to stop openSUSE from doing whatever causes this during installation?

Hi There,

It sounds like the boot loader was corrupted when you installed Suse. If you accept all defaults, it will attempt to install Grub, which normally works well.

Don’t worry - it is pretty easy to fix. There should be no reason to reinstall either Windows or Suse.

Just boot to the Suse CD / DVD and use rescue mode. If you dig around you should be able to boot the existing Suse install. Once booted into Suse, you can reinstall Grub using Yast - it will find your XP install and created a new grub.conf file and reinstall the boot load part of Grub.

Another alternative is to use the SuperGrub boot disk. This will let you reinstall grub, boot an existing OS (Windows or Linux) or restore a Windows boot loader. You can get SuperGrub from Super Grub Disk Webpage

Don’t worry - this is a pretty easy thing to fix and once you get the hang of it, you will find it plenty handy.

Pete

Looks like you can only boot to openSUSE? Is that right? If you can, then post the contents of the Grub config file for us to look at. It’s /boot/grub/menu.lst. Also post the dialogue you get in a console in response to this command:

sudo /sbin/fdisk -l

Those will show us how your partitions are organised and how Grub sees them.

When I try to open this file in the file browser, it says “an error occured while loading media: /sda6/boot/grub/menu.lst” Am I trying to open the wrong file, or is this what’s causing the problem?

sudo /sbin/fdisk -l

Those will show us how your partitions are organised and how Grub sees them.[/QUOTE]
entering this command in the terminal tells me that “-1” is an invalid option and brings up instructions for the usage of fdisk.

I’m going to try the Super Grub boot disk. I just started with linux, and know only the basics, but it seems like the Windows boot loader is the problem, and Super Grub could help out.

Try typing a lowercase L instead of the number one. :wink:

Try this command:

sudo cat /boot/grub/menu.lst

Good luck.

I suggest looking at this When you restart your computer or upgrade to Windows XP, you receive the “STOP 0x000000ED UNMOUNTABLE_BOOT_VOLUME” error message. The error is not thrown by the boot loader (ntldr) but by the OS when it is attempting to mount the Windows root partition. (It can also be due to cabling or bios issues, but from your description does not sound like that is applicable). The solution is to run chkdisk against the volume. If you have XP installation media (sound like you do) you can do this booting the CD into the Recovery Console command line.

How did this happen? Impossible to say, although it may be due to an abnormal shutdown of Windows. openSUSE does not access the Windows filesystem at all during installation.

Re-installing the boot loader didn’t do anything, whether it was from SuperGrub or YaST.

here are the results of the fdisk:

device    Boot   Start    end    Blocks    Id  System
/dev/sda1        *      1       1275   10241406  7   HPFS/NTFS
/dev/sda2               1276  121601   966518595 f   Win96 Ext'd (LBA)
/dev/sda5               1276    1537   2104483+  82  Linux swap / Solaris
/dev/sda6               1538    4148   20972826  83  Linux
/dev/sda7               4149  121601   943441191 83  Linux

And here are the contents of menu.1st:


# Modified by YaST2. Last modification on Sun Dec  7 18:23:19 GMT 2008
default 0
timeout 8
gfxmenu (hd0,5)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE
    root(hd0,5)
    kernal /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_WDC_WD1001FALS-_WD-WMAV0280080-part6 vga=0x317 resume=/dev/sda5 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Wndows
     rootnoverify (hd0,5)
     chainloader (hd0,0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE
    root(hd0,5)
    kernal /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_WDC_WD1001FALS-_WD-WMAV0280080-part6 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    inited /boot/initrd-2.6.22.5-31-default


No, I’m sure this is a problem with linux. running chkdisk was the first thing I tried. It comes up with “the volume appears to contain one or more unrecoverable problems.” However, I can reinstall windows fine. It is only when I install openSUSE from a live CD that I get the UNMOUNTABLE_BOOT_VOLUME error. I’ve done this twice now, I am absolutely 100% sure that the linux install is what’s ****ing up windows.

I’ve done some in-depth technical investigation into the problem (my morbid curiosity). I’ll try to have it all collated and simplified for posting back here later today. There are strong indications that there is an underlying complex cause - while the error messages generally speaking point to data not being where it is expected to be, this appears to be a secondary problem induced by faulty disk writes.

Let me ask a few questions now that may help in narrowing down the possibilities:

When you installed XP, did you also install SP2? And is the disk >128GB?

Is the disk IDE? Did it come with the machine? If you installed it, can you confirm it is connected with an 80-pin (rather than 40-pin) cable?

Have you made any changes to the disk configuration in the bios?

Again, I’ll post back later today.

Unfortunately, the problem you have can be caused by quite a number of things. This is probably far more complex than it appears. I’ve tried to condense all the data down to digestible form.

The error “unmountable boot volume” on its face suggests a problem with the filesystem, the partition table, the boot sector, or the MFT (the latter 3 required to get to the filesystem). If the problem is, for example, broken chains or missing file/directory blocks, then chkdisk /r can repair it. Sometimes the file system problem is deep, and chkdisk must be run several times. It may only repair part of the problem on its first run, needing to be re-initialized in another pass to continue repairing. It can take hours to do these passes, too. So the important first thing to do is to try to use chkdisk at least 3 times from the Recovery Console. Unfortunately, across all the posts on this error that I reviewed (and I looked at all I could find), only a small percentage were fixed this way. Rarely a chkdisk followed up with /fixmbr or /fixboot resolved the problem. But most attempts using these commands did nothing or also returned errors. The Testdisk tool can repair the MFT, but when tried either the attempt failed or that did not correct the problem. Much more often the secondary error message occurs that you saw. So in the vast majority of cases the problem is elsewhere. And, it is also very important to note that even if chkdisk does fix the problem, unless there was an apparent hit to the disk or filesystem while mounted (which does not appear to apply to your case), then there is still a distinct probability of an underlying more serious issue.

That issue is disk writes. The reason that a particular block of data cannot be properly accessed, and the problem is not in the structure of the filesystem (which would be reparable by chkdisk), is that the data is not where it is supposed to be or the data that is there is corrupt or the sectors on the disk are bad. This is caused by faulty writes. Now, occasionally the culprit is in software or firmware. For example, NTFS on XP had a timer flaw which, when used on a disk that caches, can result in bad writes to the filesystem; the solution is a patch in SP 2. Or, the problem has been traced to a bios flaw or a configuration setting in the bios which creates a problem for the particular drive (hence MS recommendation to change the bios disk translation from “Auto” to “Large”, or problems associated with large disks the bios was not originally written to handle, etc.). But again, these causes are by far in the minority.

Most often the problem is in hardware. MS advises checking that the IDE cable is in fact 80-pin and not 40-pin (the connector looks the same but on 80-pin the wires are noticeably thinner). Sometimes the cable has worked loose or is faulty, or sometimes the connector needs to be pulled and re-seated in the socket. Sometimes switching the disk to a different channel (for IDE) or port (for SATA) is the fix (pointing to a flakiness in the controller or mobo). The problem has even been traced to a flaw in the Southbridge or in RAM. But most often the problem is with the disk itself, therefore it is recommended to check the disk with the manufacturer’s low-level diagnostic tools. Spinrite is a terrific commercial ($89) product excellent for this purpose. It’s conceivable a SMART disk diagnostic may trap the problem, but this is not at all guaranteed. But note that finding and repairing bad sectors may actually just mask the problem, and in your case with newly installed OS’s, would be pointless.

Something that might be useful on your machine, if an option, would be to install XP and linux on a different disk or, again, the same disk connected differently. That may help isolate the problem better.

I should add that one thing that can make this extra frustrating is that it can be random. This is consistent with hardware issues of the nature described above.

Finally, when I searched on the error messages I found <5% mentioning linux. And even there, the problem description did not match yours, i.e., an association with installing linux following Windows. What is conceivable is that during your installation, either of Windows or openSUSE, faulty writes were made to the MBR or another block of data thus inducing the error you got.

That’s the sum of the information I could find. Regrettably there is nothing conclusive, consistent with the obscure and random nature of the problem.

Let me ask a few questions now that may help in narrowing down the possibilities:

When you installed XP, did you also install SP2? And is the disk >128GB?

No, I installed nothing but a few drivers. When I tried to defrag the windows partition before the openSUSE install, it came up with 3 files it couldn’t defragment (if this at all helps)

The hard drive is a brand new 1TB western digital, however, I installed windows on a 10gb partition.

Is the disk IDE? Did it come with the machine? If you installed it, can you confirm it is connected with an 80-pin (rather than 40-pin) cable?

It is a SATA disk.

Have you made any changes to the disk configuration in the bios?

No, everything is at their defaults.

The help is much appreciated. Sorry if I seem to be blunt and to-the-point sometimes, but this experience just seems a lot more frusterating than it should be, and english is my second languae. Again, thanks for all the help so far :slight_smile:

With a disk of that size, I suspect the problem is that you did not install SP 2 or at least SP 1. SP 1 added 48-bit LBA necessary for large drives (the bios must support it, too). Without it, you will get write errors. I have seen reports indicating SP 2 is also required, but I have not personally confirmed that. You can find SP 2 as a separate download file; it includes everything previously in SP 1. That is the very first thing you should do. That your defrag on a fresh install found files it could not defrag, adds to this probability.

If that does not solve the problem, then you need to look for a hardware problem. I would research the WD knowledge base for any disk writes type problem plus use WD’s diagnostic tools to check the disk drive. IIRC the tools are called “Data Lifeguard Diagnostic”; be sure to get the latest version. It is important that you use a “low-level” tool like this that scans the platters for physical defects. Keep in mind that the majority of electronic component and device failures occur when they are new (in electronics manufacturing this is known as “infant mortality”).

Of course, also make sure that the SATA cables are seated firmly, that the drive is jumpered for 3.0, and that the chipset and bios supports 3.0 (if not, jumper the drive to 1.5).

Good luck.

> Sorry if I seem to be blunt and to-the-point sometimes … english is my
> second languae.

Your english is GREAT!!
Just hang-in, because in his (mingus725) hand, you are in GOOD hands!