OpenSUSE makes me angry

Ive been using opensuse since it started but im really turned off lately… I stuck with 11.1 because 11.2 was so horrible, but i just had to reinstall again because i downloaded a bad update and in so doing im reminded of how utterly difficult and insane multimedia is for opensuse…

I currently have Sabayon, Debian, and Fedora and none of them are even 1 / 100th as difficult as opensuse in regards multimedia. About a month before 11.2 came out opensuse went straight to hell and It’s just been **** ever since. Both 11.1 and 11.2. What the hell happened???

Clicking the mouse 5-6 times is difficult?

I guess people have varying ideas of what “difficult” is.

No that would be very nice… I suppose you mean the opensuse-community one click ymp? doesn’t work anymore, it used to though. it’s stil necessary and helpful but a lot of other **** has to be done in exactly perfect sequential order first

No, I mean it does work and that’s all you have to do play almost every imaginable format out there.

I can install fresh 11.2, update it (normal updates) and then run the 1-click installer and bang I’ve got all the major formats playing in KDE. No tweaking, no juggling around - it just works.

You could have come here asking for support to get your 11.2 working. I’m quite sure, you would have gotten it to run great with some help from here.
There’s a very fine guide to Restricted Media Formats on the forums.

Though I understand your annoyance about things not working like you wish them to work, I suggest you start using the forums to get and give support. That will bring you more than the tiny relief of a rant.

The guide in the media forums ended up being the one that worked, if only i knew that 8 installs ago. Still the other distros are much easier and dont require as precise methods (a user can just do it their way) but it would be nice if they had some sort of disclamor to see http://whatever for instructions or something because new users wont stick around if they go through what i went through.

And 11.2 i didn’t even bother with multimedia, the introductory experience was enough to send me back to 11.1

Oh dingleb’s anger brought back some fine memories when I used to deal with Fedora (version 5 or 6 as I recall). Let multimedia, not a lot of other things worked as well, like beagle so no file search. Later a release came out stating that there was a typo in the kernel. How unfortunate.and very frustrating.
While community contributions are great, they can’t be perfect. But contributions are even more valuable when authors/initiators are open to criticism. Granted, a lot of “next-next-finish” mentality gets transplanted into OSS world from the windows realm. So now we expect things to just work even when it means exposure to lawsuits. Those that offer playback of proprietary formats on OSS platforms very likely resolved the legalese first and equally likely by throwing some $$$ at it.
IMHO, building your own priority list of things you want from your OSS system would be most helpfull. Are you pressed by deadlines you absolutely must meet with the multimedia playing back proprietary formats? Is using BlackBerry Desktop Manager on my openSUSE laptop via virtualized XP an absolute must by say monday? I must admit I am not as expirienced user of openSUSe enough to comment on differencies between 11.1 and 11.2 but I like what I see enough to give up not only the win partition but also the ubuntu partition on my personal laptop in favor of openSUSE…

You’ve been using openSUSE from the beginning and you only come to the forums now to complain? oS is a community based effort. While it’s “free,” people are expected to give back in ways such as reporting bugs or sharing knowledge in forums or lists. It ain’t free as in free beer.

The extra step for multimedia is due to proprietary licensing. Novell and do not want to risk lawsuits for infringing on these patents. This has never caused me any problems, the Packman repo provides all of the packages needed to play any format. There are instructions abound for getting this started. If you’d asked in these forums, somebody almost certainly would have gotten you going without problems.

I did a search on your handle and could not find one post asking for help on 11.2 not mentioning multimedia.

We are a support forum, not a development forum. We are volunteers who spend our own free time to help. We do not have any more influence over openSUSE than you, and the way we do have minor influence is not here on the forum … rather its via feature requests OUTSIDE of the forum and via bug reports OUTSIDE of the forum.

If you politely post asking for help, I suspect you will find many volunteers responding to your request for help. Its still not too late. Simply start an new thread in the Installation subforum area and ask for help, noting the problem you encountered.

If you want to influence the design of 11.3 then openFATE is the place to go and if you have a problem with openSUSE-11.2 where you want to bring official attention to it, then a bug report is what is most helpful and will have the BIGGEST impact: Submitting Bug Reports - openSUSE You can use your forum username and forum password to logon when raising a bug report. Posting a rant on our forum is a waste of your time, and if you are like me, you likely do not have the time to waste.

I’ve installed openSUSE-11.2 on 5 PCs, and I have to say its superior on all 5 than 11.1. Now one of those 5 required extra tuning to be better (I had to download a new version of the radeon driver) and another of those 5 required that I wait 4 months after the 11.2 release until a proprietary graphic driver was available. But the remaining 3 of 5 were smooth.

I have NOT installed 11.2 on another (6th) PC, because booting to the liveCD indicated to me that there would be problems. I’ve kept that on 11.1. And on that 6th PC I note that 11.1 runs well. Overall, on all 6 PCs, both 11.1 and 11.2 run very good, and I am very happy with it.

Reference multimedia, once you get the technique down you will find it a breeze on openSUSE.

Note this is a computer operating system, and despite my being a big openSUSE fan, I would be the 1st to say there are far more important things than computers and most DEFINITELY more important things than openSUSE. Next time you have problem with an install, don’t waste your time getting angry. Simply post on our forum, or go to IRC channel freenode #suse and advise users there of your problem with the install. I suspect you will quickly get a good assessment in return as to what the problem may be, and whether its worth moving to 11.2 or staying with 11.1 or 11.x.

And above all, take it easy. The time we have in life is far too short and far too valuable to spend time getting angry over small things like computers.

Yeh I agree with this post for the most part, mainly because there is a lot you have to do to set multimedia up.
On say Ubuntu I can install Ubuntu restricted extras that gives me almost everything except libdvdcss, but its easy enough to install.
The biggest one I dont get is having to install the xine codecs and all the gstreamer packages separately, both should be installed with the multimedia package.
Plus realplayer is a pain to install too

Then you should also know that we are a support forum of volunteers and not developers.

You are wasting your time here.

The place to post is on openFate (link above) and to write bug reports.

Wasting bandwidth here with such posts accomplishes nothing. Its far better to spend one’s time helping those who ask for help .

Seriously, something must go really wrong on Dinglebs (or TaraIkedas) side - setting up multimedia is way way way easy on openSUSE, especially when using the .ymp (the only extra package I am missing from it is ‘flac’, which becomes more and more popular, but it easily can be fetched from oss) - unfortunately I don’t see any information about the actual symptoms here, except that it does not work.

Its called an opinion, and I have a right to have one.
If bandwidth was such a big issue then close off the forums, or restrict everyone to one forum and one post.
No need to be rude even if you are a mod.
Look this is one of the downsides to openSUSE, every distro has one.
You are just mad because I mentioned Ubuntu, or mad at the OP because he mentioned other distros.
If we said that openSUSE was perfect and was the best thing since sliced bread then we would not be having this arguement.
But oh no we have to have different opinions, heaven forbid!
This is a web forum, the forum is called general chit chat, not “all hail the everlasting perfection that is openSUSE!”
Geez if you dont like people posting non openSUSE posts or people posting complaints about it then dont make a general chit chat forum, people will have different experiences you know.

My experience is this, even if the YMP does work for the most part there are some drawbacks to it, the two that really mess it up for me is to have to install the xine-codecs package and the gstreamer stuff.
xine codecs is such a crucial package to this and maybe it should be in the ymp multimedia installer.

Meh, I set up multimedia using one-click install on a couple of machines. Just worked. Don’t know what all the fuss is about.

It all goes down to personal experience, and the computer.
Hey sometimes computers have different personalities, computer A and B could have the exact same hardware/ software but have completely different experiences.
I have seen it happen many times.

By the way sorry for my above comments if they seemed rude, but hey I thought oldcpu was out of line with his comment.
I have a sarcastic streak, I cant help it.

I have a sarcastic streak, I cant help it.

You are very welcome here, but this was a bit out of line… I still think oldcpus comment was provoking an angry feedback a bit - saying “You are wasting your time here.” is just not very polite, but, TaraIkeda, we had this discussion quite a bit here on the forum, didn’t we?

Hey sometimes computers have different personalities, computer A and B could have the exact same hardware/ software but have completely different experiences.
I have seen it happen many times.

I earn money by doing private support (mainly for openSUSE), so I have set up quite a lot of SuSEs on many different machines, and while I have experienced one-clickers to fail (since many of them are badly worked out) I still recommend the multimedia-.ymp because it always did what it should do. So… from my point of view it seems unlikely that there’s no explanation for the behaviour on your system. And even if not, you should accept that setting up multimedia on a SuSE is n00b-friendly and easy as pie for at least 99.9% of all users.

Hey I just happen to be vocal on some things, if I see something I dont like I will blurt out against it.

you should accept that setting up multimedia on a SuSE is n00b-friendly and easy as pie for at least 99.9% of all users.

No I would take that factor down to at least 80%, saying 99.9 is too full of itself.
People might have issues with it in some shape or form, for me its more of an annoyance to download xine-codecs and gstreamer seperately then a real bug in the traditional sense.
But openSUSE is still easier then some other distros on multimedia, Mandriva is a pain in the you know what in that department.
So is Debian

People might have issues with it in some shape or form, for me its more of an annoyance to download xine-codecs and gstreamer seperately then a real bug in the traditional sense.

What exactly is the bug (when using .ymps)?

Again for me it doesnt install xine-codecs or gstreamer, at least not on the install I had.
But like I said I am quite sure its not a bug and just a nuisance.
I had to install VLC to get what I needed for most of the codecs.
Plus getting quicktime vids= pain, I never had an issue with quicktime vids in ubuntu

There must have been some error-output when you used the .ymp - remember that nothing on a computer system is coincidental except the output of a random generator (so I do not agree on your comment referring to “different personalities” of machines).

But like I said I am quite sure its not a bug and just a nuisance.

That would be a bug - what do you mean, that the .ymp is trying to make you angry? C’mon…

Quicktime-vids are managed by the package ‘w32codec-all’ as far as I recall.